summaryrefslogtreecommitdiff
path: root/vscodium.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-08-07 07:31:59 +0000
committerCoprDistGit <infra@openeuler.org>2024-08-07 07:31:59 +0000
commitb89039c5688ab75fffa3d806119eb053cc326660 (patch)
tree4f81cc86bdbf24a6bf6ea840db44c2ca4b21cf23 /vscodium.spec
parentfa9c0e08315a612470ef72ca5ac658663634f408 (diff)
automatic import of vscodium
Diffstat (limited to 'vscodium.spec')
-rw-r--r--vscodium.spec41
1 files changed, 35 insertions, 6 deletions
diff --git a/vscodium.spec b/vscodium.spec
index aa065a1..f128cf7 100644
--- a/vscodium.spec
+++ b/vscodium.spec
@@ -1,21 +1,34 @@
%global debug_package %{nil}
-%define vscode_version 1.91.0
+%define vscode_version 1.91.1
+
+%define jsdebugcompanion_version 1.1.2
+%define jsdebug_version 1.91.0
+%define vscodejsprofiletable_version 1.0.9
Name: vscodium
-Version: %{vscode_version}.24190
+Version: %{vscode_version}.24193
Release: 1
Summary: Free/Libre Open Source Software Binaries of VS Code
License: MIT
URL: https://github.com/VSCodium/vscodium
-Source0: https://github.com/VSCodium/vscodium/archive/%{version}.tar.gz
-Source1: https://github.com/microsoft/vscode/archive/%{vscode_version}.tar.gz
+
+Source0: https://github.com/VSCodium/vscodium/archive/refs/tags/%{version}.tar.gz
+Source1: https://github.com/microsoft/vscode/archive/refs/tags/%{vscode_version}.tar.gz
+
+Source2: https://github.com/microsoft/vscode-js-debug-companion/releases/download/v%{jsdebugcompanion_version}/ms-vscode.js-debug-companion.%{jsdebugcompanion_version}.vsix
+Source3: https://github.com/microsoft/vscode-js-debug/releases/download/v%{jsdebug_version}/ms-vscode.js-debug.%{jsdebug_version}.vsix
+Source4: https://github.com/microsoft/vscode-js-profile-visualizer/releases/download/v%{vscodejsprofiletable_version}/ms-vscode.vscode-js-profile-table.%{vscodejsprofiletable_version}.vsix
+Source5: vendor.tar
Patch0: no-exec-git.patch
+Patch1: use-local-vsix.patch
+Patch2: yarn-offline.patch
+Patch3: ripgrep.patch
Requires: glibc nodejs fontconfig libXtst cairo alsa-lib nss libnotify libxcb libxkbfile libsecret
-BuildRequires: gcc g++ make pkg-config npm libxcb-devel libxkbfile-devel krb5-devel libsecret-devel yarnpkg git python3 jq
+BuildRequires: gcc g++ make pkg-config libxcb-devel libxkbfile-devel krb5-devel libsecret-devel nodejs-yarn git python3 jq nodejs-devel
%description
VSCodium is a community-driven, freely-licensed binary distribution of Microsoft’s editor VS Code.
@@ -23,10 +36,24 @@ VSCodium is a community-driven, freely-licensed binary distribution of Microsoft
%prep
%setup -q
-tar -xzf %{SOURCE1} -C %{_builddir}/%{name}-%{version}
+
+tar -xvf %{SOURCE1} -C %{_builddir}/%{name}-%{version}
mv %{_builddir}/%{name}-%{version}/vscode-%{vscode_version} %{_builddir}/%{name}-%{version}/vscode
+cp %{SOURCE2} %{_builddir}/%{name}-%{version}
+cp %{SOURCE3} %{_builddir}/%{name}-%{version}
+cp %{SOURCE4} %{_builddir}/%{name}-%{version}
+
%patch 0
+%patch 1
+%patch 2
+%patch 3
+
+mkdir -p %{_builddir}/%{name}-%{version}/vendor
+tar -xvf %{SOURCE5} -C %{_builddir}/%{name}-%{version}/vendor
+
+yarn config set yarn-offline-mirror %{_builddir}/%{name}-%{version}/vendor
+echo "yarn-offline-mirror %{_builddir}/%{name}-%{version}/vendor" >> %{_builddir}/%{name}-%{version}/vscode/.yarnrc
%build
@@ -43,6 +70,8 @@ export VSCODE_SKIP_NODE_VERSION_CHECK="yes"
export SHOULD_BUILD_REH="no"
export OS_NAME="linux"
+export ELECTRON_MIRROR="https://mirrors.huaweicloud.com/electron/"
+
UNAME_ARCH=$( uname -m )
if [[ "${UNAME_ARCH}" == "arm64" ]]; then