summaryrefslogtreecommitdiff
path: root/lammps.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-12-13 05:27:55 +0000
committerCoprDistGit <infra@openeuler.org>2024-12-13 05:27:55 +0000
commit14c81584cab72572051fed87e35b2b4f154e087c (patch)
treebbb1faca5a4cc943cd0cd96c6852c59478dad5d4 /lammps.spec
parent16e646c1f25ed70d18997fbf0fe7d099f27215a6 (diff)
automatic import of lammps
Diffstat (limited to 'lammps.spec')
-rw-r--r--lammps.spec36
1 files changed, 7 insertions, 29 deletions
diff --git a/lammps.spec b/lammps.spec
index fdc3a5d..f9485f6 100644
--- a/lammps.spec
+++ b/lammps.spec
@@ -7,34 +7,18 @@
%global cmake_blas_flags -DBLAS_LIBRARIES=%{_libdir}/lib%{blaslib}%{blasvar}.so -DLAPACK_LIBRARIES=%{_libdir}/lib%{blaslib}%{blasvar}.so
Name: lammps
-%if %{git}
-Version: 20241119^%{shortcommit}
-%else
Version: 20241119
-%endif
-%global uversion %(v=%{version}; \
- patch=${v##*.}; [[ $v = $patch ]] && patch= \
- v=${v%%.*}; \
- months=( "" Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec ); \
- d=${v:6:2}; \
- m=${v:4:2};
- y=${v:0:4};
- echo $([[ -z $patch ]] && echo patch || echo stable)_${d#0}${months[${m#0}]}${y}$([[ -n $patch ]] && echo _update${patch}))
Release: 1%{?dist}
Summary: Molecular Dynamics Simulator
# Automatically converted from old format: GPLv2 - review is highly recommended.
License: GPL-2.0-only
Url: https://www.lammps.org/
-%if %{git}
-Source0: https://github.com/lammps/lammps/archive/%{commit}/lammps-%{commit}.tar.gz#/%{name}-%{commit}.tar.gz
-%else
-Source0: https://github.com/lammps/lammps/archive/%{uversion}.tar.gz#/%{name}-%{uversion}.tar.gz
-%endif
-Source1: https://github.com/google/googletest/archive/release-1.12.1.tar.gz#/googletest-1.12.1.tar.gz
-Source2: https://pyyaml.org/download/libyaml/yaml-0.2.5.tar.gz
-Source3: https://download.lammps.org/thirdparty/opencl-loader-2024.05.09.tar.gz
-Source4: https://github.com/spglib/spglib/archive/refs/tags/v1.11.2.1.tar.gz#/spglib-1.11.2.1.tar.gz
-Source5: https://github.com/icl-utk-edu/heffte/archive/refs/tags/v2.4.0.tar.gz
+Source0: lammps-patch_19Nov2024.tar.gz
+Source1: googletest-1.12.1.tar.gz
+Source2: yaml-0.2.5.tar.gz
+Source3: opencl-loader-2024.05.09.tar.gz
+Source4: spglib-1.11.2.1.tar.gz
+Source5: heffte-2.4.0.tar.gz
Patch0: 0-lammps-change-cmake-download.patch
@@ -50,12 +34,10 @@ BuildRequires: libpng-devel
BuildRequires: libjpeg-devel
%ifnarch %ix86
BuildRequires: openmpi-devel
-BuildRequires: heffte-openmpi-devel
BuildRequires: python3-mpi4py-openmpi
BuildRequires: python3-mpi4py-mpich
%endif
BuildRequires: mpich-devel
-BuildRequires: heffte-mpich-devel
BuildRequires: python3-devel
BuildRequires: python3-numpy
BuildRequires: fftw3-devel
@@ -211,11 +193,7 @@ BuildRequires: python3-wheel
BuildRequires: python3-build
%prep
-%if %{git}
-%setup -q -n %{name}-%{commit}
-%else
-%setup -q -n %{name}-%{uversion}
-%endif
+%autosetup -p1
cp %{SOURCE5} cmake/
%build