summaryrefslogtreecommitdiff
path: root/lammps.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-12-13 08:47:04 +0000
committerCoprDistGit <infra@openeuler.org>2024-12-13 08:47:04 +0000
commit82d207cf0339ff4d3fbbb07a48483f2af1f2ce99 (patch)
treec1a70d59991900a54a4923eea1a31b96d5820c33 /lammps.spec
parent294d3d2ebd2d18294911ce13f0a547ada103f070 (diff)
automatic import of lammps
Diffstat (limited to 'lammps.spec')
-rw-r--r--lammps.spec4
1 files changed, 2 insertions, 2 deletions
diff --git a/lammps.spec b/lammps.spec
index 5b66b68..9fc517e 100644
--- a/lammps.spec
+++ b/lammps.spec
@@ -236,7 +236,7 @@ for mpi in '' mpich %{?with_openmpi:openmpi} ; do
${mpi:+-DBUILD_MPI=ON -DFFT_USE_HEFFTE=ON -DCMAKE_EXE_LINKER_FLAGS="%{__global_ldflags} -Wl,-rpath -Wl,${MPI_LIB} -Wl,--enable-new-dtags" -DCMAKE_SHARED_LINKER_FLAGS="%{__global_ldflags} -Wl,-rpath -Wl,${MPI_LIB} -Wl,--enable-new-dtags" $(test "$mpi" != openmpi || echo "-DMPIEXEC_PREFLAGS=--oversubscribe") } \
$(test -z "${mpi}" && echo -DBUILD_MPI=OFF -DBUILD_LAMMPS_SHELL=ON -DBUILD_TOOLS=ON)
%make_build
-# test -n "${mpi}" && module unload mpi/${mpi}-%{_arch}
+ test -n "${mpi}" && module unload mpi/${mpi}-%{_arch}
done
cd ../python
@@ -251,7 +251,7 @@ for mpi in '' mpich %{?with_openmpi:openmpi} ; do
%make_install -C .obj-%{_target_platform}
done
-cd python
+cd ../python
%py3_install
%py3_save_files lammps