summaryrefslogtreecommitdiff
path: root/lammps.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-12-15 09:52:33 +0000
committerCoprDistGit <infra@openeuler.org>2024-12-15 09:52:33 +0000
commitea7f5b1c63acf799d7de8064dc562f34867ca400 (patch)
treecbb53008966e0949bfe2025dcc2a469aec729458 /lammps.spec
parenta1ae9a4a815d069fc761690c63761db13853f4ed (diff)
automatic import of lammps
Diffstat (limited to 'lammps.spec')
-rw-r--r--lammps.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/lammps.spec b/lammps.spec
index c2d1e49..8410d8b 100644
--- a/lammps.spec
+++ b/lammps.spec
@@ -174,6 +174,7 @@ BuildRequires: python3-build
cp %{SOURCE5} cmake/
%build
+cd cmake
set +e
. /etc/profile.d/modules.sh
set -e
@@ -181,9 +182,9 @@ set -e
for mpi in '' mpich %{?with_openmpi:openmpi} ; do
test -n "${mpi}" && module load mpi/${mpi}-%{_arch}
#python wrapper isn't mpi specific
- %cmake ./cmake \
- -C cmake/presets/all_on.cmake \
- -C cmake/presets/nolib.cmake \
+ %cmake . \
+ -C ./presets/all_on.cmake \
+ -C ./presets/nolib.cmake \
%{cmake_blas_flags} \
-DCMAKE_TUNE_FLAGS='' \
-DCMAKE_CUSTOM_LINKER="default" \
@@ -218,6 +219,7 @@ cd ../python
%py3_build
%install
+cd cmake
set +e
. /etc/profile.d/modules.sh
set -e
@@ -230,7 +232,7 @@ cd python
%py3_install
%check
-
+cd cmake
%global testargs --label-exclude unstable --exclude-regex '\(SimpleCommands\|Variables\|ComputeGlobal\|MolPairStyle:coul_slater_long\|AtomicPairStyle:meam_spline\|FixTimestep:.*\|.*tip4p.*\)'
%ifnarch %ix86