summaryrefslogtreecommitdiff
path: root/lammps.spec
diff options
context:
space:
mode:
Diffstat (limited to 'lammps.spec')
-rw-r--r--lammps.spec9
1 files changed, 2 insertions, 7 deletions
diff --git a/lammps.spec b/lammps.spec
index 10bc267..67ab601 100644
--- a/lammps.spec
+++ b/lammps.spec
@@ -174,9 +174,8 @@ BuildRequires: python3-build
cp %{SOURCE5} cmake/
%build
-set +e
. /etc/profile.d/modules.sh
-set -e
+
for mpi in '' mpich %{?with_openmpi:openmpi} ; do
test -n "${mpi}" && module load mpi/${mpi}-%{_arch}
if [ -z "$mpi" ]; then
@@ -222,7 +221,7 @@ for mpi in '' mpich %{?with_openmpi:openmpi} ; do
-DCMAKE_INSTALL_BINDIR=${MPI_BIN:-%{_bindir}} -DCMAKE_INSTALL_LIBDIR=${MPI_LIB:-%{_libdir}} -DLAMMPS_MACHINE="${MPI_SUFFIX#_}" -DLAMMPS_LIB_SUFFIX="${MPI_SUFFIX#_}" -DCMAKE_INSTALL_MANDIR=${MPI_MAN:-%{_mandir}} \
${mpi:+-DBUILD_MPI=ON -DFFT_USE_HEFFTE=ON -DCMAKE_EXE_LINKER_FLAGS="%{__global_ldflags} -Wl,-rpath -Wl,${MPI_LIB} -Wl,--enable-new-dtags" -DCMAKE_SHARED_LINKER_FLAGS="%{__global_ldflags} -Wl,-rpath -Wl,${MPI_LIB} -Wl,--enable-new-dtags" $(test "$mpi" != openmpi || echo "-DMPIEXEC_PREFLAGS=--oversubscribe") } \
$(test -z "${mpi}" && echo -DBUILD_MPI=OFF -DBUILD_LAMMPS_SHELL=ON -DBUILD_TOOLS=ON)
- cmake --build . -j64
+ cmake --build . -j8
test -n "${mpi}" && module unload mpi/${mpi}-%{_arch}
cd ..
done
@@ -231,9 +230,7 @@ cd python
%py3_build
%install
-set +e
. /etc/profile.d/modules.sh
-set -e
for mpi in '' mpich %{?with_openmpi:openmpi} ; do
if [ -z "$mpi" ]; then
@@ -259,9 +256,7 @@ cd python
%global testargs --label-exclude unstable --exclude-regex '\(SimpleCommands\|Variables\|ComputeGlobal\|MolPairStyle:coul_slater_long\|AtomicPairStyle:meam_spline\|FixTimestep:.*\|.*tip4p.*\|LibraryMPI\|MPILoadBalancing\|FileOperations\|Groups\|SetProperty\|AtomicPairStyle:lj_cut_sphere\|AtomicPairStyle:lj_expand_sphere\|AtomicPairStyle:meam_ms\|AtomicPairStyle:pedone\|DihedralStyle:cosine_squared_restricted\|BondStyle:harmonic_restrain\|TestPairList\)'
%endif
-set +e
. /etc/profile.d/modules.sh
-set -e
for mpi in '' mpich %{?with_openmpi:openmpi} %{?el7:openmpi3} ; do
old_PYTHONPATH="${PYTHONPATH}"