summaryrefslogtreecommitdiff
path: root/fc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'fc.spec')
-rw-r--r--fc.spec7
1 files changed, 4 insertions, 3 deletions
diff --git a/fc.spec b/fc.spec
index 453b2f4..bfb8826 100644
--- a/fc.spec
+++ b/fc.spec
@@ -14,7 +14,7 @@ License: MulanPSL2
URL: https://atomgit.com/openeulercompetitioninfo/meiyoumingzi
Source0: https://atomgit.com/openeulercompetitioninfo/meiyoumingzi/repository/archive.tar.gz?ref=master#/%{pkg_name}-%{pkg_version}.tar.gz
-BuildRequires: wget
+BuildRequires: tree
BuildRequires: gcc
BuildRequires: g++
@@ -24,13 +24,14 @@ BuildRequires: g++
%prep
echo "install Cangjie"
%ifarch x86_64
- wget 'https://cangjie-lang.cn/v1/files/auth/downLoad?nsId=142267&fileName=Cangjie-0.53.18-linux_x64.tar.gz&objectKey=67a2c8976a75297d1cdc1d4c' -O Cangjie.tar.gz
+ curl -o Cangjie.tar.gz 'https://cangjie-lang.cn/v1/files/auth/downLoad?nsId=142267&fileName=Cangjie-0.53.18-linux_x64.tar.gz&objectKey=67a2c8976a75297d1cdc1d4c'
%else
- wget 'https://cangjie-lang.cn/v1/files/auth/downLoad?nsId=142267&fileName=Cangjie-0.53.18-linux_aarch64.tar.gz&objectKey=67a2c8606a75297d1cdc1d48' -O Cangjie.tar.gz
+ curl -o Cangjie.tar.gz 'https://cangjie-lang.cn/v1/files/auth/downLoad?nsId=142267&fileName=Cangjie-0.53.18-linux_aarch64.tar.gz&objectKey=67a2c8606a75297d1cdc1d48'
%endif
tar xvf Cangjie.tar.gz
%build
+tree /builddir/build -L 3
source cangjie/envsetup.sh
cjc -v