summaryrefslogtreecommitdiff
path: root/python-onnxruntime.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-onnxruntime.spec')
-rw-r--r--python-onnxruntime.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/python-onnxruntime.spec b/python-onnxruntime.spec
index 261f906..25a7695 100644
--- a/python-onnxruntime.spec
+++ b/python-onnxruntime.spec
@@ -75,10 +75,15 @@ bash build.sh --build_dir build \
--build_shared_lib \
--skip_submodule_sync
+# Build python libs
+mv ./onnxruntime ./onnxruntime.src
+cp -R %{_builddir}/build/RelWithDebInfo/onnxruntime ./onnxruntime
+cp %{_builddir}/build/RelWithDebInfo/requirements.txt ./requirements.txt
%pyproject_build
%install
-
+# onnxruntime
+%__cmake --install %{_builddir}/build/RelWithDebInfo --prefix=%{buildroot}
# doc
mkdir -p "%{buildroot}/%{_docdir}/"
cp --preserve=timestamps -r "./docs/" "%{buildroot}/%{_docdir}/%{name}"