summaryrefslogtreecommitdiff
path: root/python-datasets.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-datasets.spec')
-rw-r--r--python-datasets.spec40
1 files changed, 31 insertions, 9 deletions
diff --git a/python-datasets.spec b/python-datasets.spec
index 293176b..ca45ca8 100644
--- a/python-datasets.spec
+++ b/python-datasets.spec
@@ -1,12 +1,12 @@
-%global pypi_name datasets
-%global pypi_version 2.18.0
+%global pkg_name datasets
+%global pkg_version 2.18.0
%global pkg_summary HuggingFace community-driven open-source library of datasets
%global pkg_description %{expand:
%{pkg_summary}}
-%global debug_package %{nil}
+%global _empty_manifest_terminate_build 0
-Name: python-%{pypi_name}
-Version: %{pypi_version}
+Name: python-%{pkg_name}
+Version: %{pkg_version}
Release: 1
Summary: %{pkg_summary}
@@ -27,27 +27,49 @@ BuildRequires: python3-pytorch >= 2.1.2
%description
%{pkg_description}
-%package -n python3-%{pypi_name}
+%package -n python3-%{pkg_name}
Summary: %{pkg_summary}
-%description -n python3-%{pypi_name}
+%description -n python3-%{pkg_name}
%{pkg_description}
+%package help
+Summary: the documents and examples for %{pkg_name}
+
+%description help
+This package contains the documents and examples for %{pkg_name}
+
%prep
-%autosetup -p1 -n %{pypi_name}-%{pypi_version}
+%autosetup -p1 -n %{pkg_name}-%{pkg_version}
%build
%pyproject_build
%install
%pyproject_install
+# help pkg files:
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/doclist.lst .
-%files -n python3-%{pypi_name}
+%files -n python3-%{pkg_name}
%license LICENSE*
%doc README*
%{python3_sitelib}/%{pypi_name}*
%{_bindir}/datasets-cli
%changelog
+* Mon Apr 15 2024 YunShu
+- add help subpackage
+
* Sun Mar 31 2024 YunShu
- add datasets 2.18.0