summaryrefslogtreecommitdiff
path: root/python-fsspec.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-fsspec.spec')
-rw-r--r--python-fsspec.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/python-fsspec.spec b/python-fsspec.spec
new file mode 100644
index 0000000..41f87d5
--- /dev/null
+++ b/python-fsspec.spec
@@ -0,0 +1,45 @@
+%global pypi_name fsspec
+%global pypi_version 2023.12.0
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1%{?dist}
+Summary: A specification that python filesystems should adhere to.
+
+License: BSD 3-Clause
+URL: https://github.com/fsspec/filesystem_spec
+Source0: %{url}/archive/refs/tags/%{version}.tar.gz#/filesystem_spec-%{version}.tar.gz
+
+BuildRequires: cmake
+BuildRequires: ninja-build
+
+BuildRequires: python3-tqdm
+BuildRequires: python3-requests
+BuildRequires: python3-devel
+
+%description
+A specification that python filesystems should adhere to.
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+
+%description -n python3-%{pypi_name}
+A specification that python filesystems should adhere to.
+
+%prep
+%autosetup -p1 -n filesystem_spec-%{pypi_version}
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.md
+%{python3_sitearch}/%{pypi_name}
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add python-fsspec