summaryrefslogtreecommitdiff
path: root/python-huggingface-hub.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-huggingface-hub.spec')
-rw-r--r--python-huggingface-hub.spec53
1 files changed, 53 insertions, 0 deletions
diff --git a/python-huggingface-hub.spec b/python-huggingface-hub.spec
new file mode 100644
index 0000000..3244e7a
--- /dev/null
+++ b/python-huggingface-hub.spec
@@ -0,0 +1,53 @@
+%global pypi_name huggingface-hub
+%global pypi_version 0.22.2
+%global pkg_summary The official Python client for the Huggingface Hub.
+%global pkg_description %{expand:
+%{pkg_summary}}
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1
+Summary: %{pkg_summary}
+
+License: Apache-2.0
+URL: https://github.com/huggingface/huggingface_hub
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/huggingface_hub-%{version}.tar.gz
+
+BuildRequires: cmake
+BuildRequires: ninja-build
+BuildRequires: g++
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+%description
+%{pkg_description}
+
+%package -n python3-%{pypi_name}
+Summary: %{pkg_summary}
+
+%description -n python3-%{pypi_name}
+%{pkg_description}
+
+%prep
+%autosetup -p1 -n huggingface_hub-%{pypi_version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README*.md
+%{python3_sitelib}/%{pypi_name}*
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add huggingface-hub 0.22.2