summaryrefslogtreecommitdiff
path: root/python-iopath.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-04-13 12:22:19 +0000
committerCoprDistGit <infra@openeuler.org>2024-04-13 12:22:19 +0000
commit7d9fe3bc2e129b8bc5c24b7bb322f769e798ce5f (patch)
tree6676c2f7108ddb20f1e2da864c19707cfd9ad6d3 /python-iopath.spec
parent80f6e866e1de6fe43df9296124c8f9639f9cf444 (diff)
automatic import of python-iopath
Diffstat (limited to 'python-iopath.spec')
-rw-r--r--python-iopath.spec48
1 files changed, 48 insertions, 0 deletions
diff --git a/python-iopath.spec b/python-iopath.spec
new file mode 100644
index 0000000..be3757d
--- /dev/null
+++ b/python-iopath.spec
@@ -0,0 +1,48 @@
+%global pypi_name iopath
+%global pypi_version 0.1.9
+%global pypi_summary Datasets, Transforms and Models specific to Computer Vision
+%global pypi_description %{pypi_summary}
+%global debug_package %{nil}
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1%{?dist}
+Summary: %{pypi_summary}
+
+License: MIT License
+URL: https://github.com/facebookresearch/iopath
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/iopath-%{version}.tar.gz
+
+BuildRequires: cmake
+BuildRequires: ninja-build
+BuildRequires: g++
+
+BuildRequires: python3-devel
+
+%description
+%{pypi_description}
+
+%package -n python3-%{pypi_name}
+Summary: %{pypi_summary}
+
+%description -n python3-%{pypi_name}
+%{pypi_description}
+
+%prep
+%autosetup -p1 -n %{pypi_name}-%{pypi_version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.md
+%{python3_sitearch}/%{pypi_name}
+%{python3_sitearch}/%{pypi_name}-*.egg-info/
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add iopath