summaryrefslogtreecommitdiff
path: root/pyporter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'pyporter.spec')
-rw-r--r--pyporter.spec12
1 files changed, 6 insertions, 6 deletions
diff --git a/pyporter.spec b/pyporter.spec
index a574679..b08d397 100644
--- a/pyporter.spec
+++ b/pyporter.spec
@@ -1,16 +1,16 @@
Name: pyporter
-Version: 1.1
+Version: 1.2
Release: 2
Summary: A rpm packager bot for python modules from pypi.org
License: Mulan PSL v2
URL: https://gitee.com/openeuler/pyporter
-Source0: https://gitee.com/openeuler/pyporter/repository/archive/v%{version}.tar.gz
+Source0: https://gitee.com/openeuler/pyporter/repository/archive/pyporter-v%{version}.tar.gz
BuildArch: noarch
%description
pyporter is a tool to create spec file and create rpm for python modules For more details, please use pyporter -h.
-BuildRequires: gcc libstdc++-devel python3-cffi python3-hatchling python3-hatch-vcs openEuler-rpm-config python-setuptools
-Requires: gcc gdb libstdc++-devel python3-cffi python-setuptools
+BuildRequires: gcc libstdc++-devel python3-cffi python3-hatchling python3-hatch-vcs openEuler-rpm-config python3-setuptools
+Requires: gcc gdb libstdc++-devel python3-cffi python3-setuptools
%package -n python3-pyporter
@@ -23,10 +23,10 @@ pyporter is a tool to create spec file and create rpm for python modules.
%autosetup -n pyporter-v%{version} -p1
%build
-%py3_build
+%pyproject_build
%install
-%py3_install
+%pyproject_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
pushd %{buildroot}
if [ -d usr/lib ]; then