From bad32cf642636c32ae6ef1df9065028dc1cf3eb0 Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Thu, 27 Mar 2025 12:28:15 +0000
Subject: automatic import of ros-humble-stomp

---
 stomp.spec | 105 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 105 insertions(+)
 create mode 100644 stomp.spec

(limited to 'stomp.spec')

diff --git a/stomp.spec b/stomp.spec
new file mode 100644
index 0000000..a5f7c16
--- /dev/null
+++ b/stomp.spec
@@ -0,0 +1,105 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName      stomp
+%define ros_distro      humble
+%define with_tests 0
+
+Name:           ros-%{ros_distro}-%{RosPkgName}
+Version:        0.1.2
+Release:        1%{?dist}%{?release_suffix}
+Summary:        This package  provides the STOMP (Stochastic Trajectory Optimization for Motion Planning) algorithm that can be used for robot motion planning tasks or other similar optimization tasks
+
+Url:            http://wiki.ros.org/stomp
+License:        Apache 2.0
+Source0:        %{name}_%{version}.orig.tar.gz
+
+Requires: console-bridge-devel
+Requires: eigen3-devel
+
+BuildRequires: console-bridge-devel
+BuildRequires: ros-%{ros_distro}-ros-industrial-cmake-boilerplate
+BuildRequires: eigen3-devel
+BuildRequires: cmake
+
+%if 0%{?with_tests}
+BuildRequires: gtest-devel
+%endif
+
+Provides:       %{name}-devel = %{version}-%{release}
+Provides:       %{name}-doc = %{version}-%{release}
+Provides:       %{name}-runtime = %{version}-%{release}
+
+%description
+This package  provides the STOMP (Stochastic Trajectory Optimization for Motion Planning) algorithm that can be used for robot motion planning tasks or other similar optimization tasks
+
+%prep
+%autosetup -p1
+
+%build
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+export ROS_DISTRO=%{ros_distro}
+export ROS_PYTHON_VERSION=%{python3_version}
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it.  It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+    -UINCLUDE_INSTALL_DIR \
+    -ULIB_INSTALL_DIR \
+    -USYSCONF_INSTALL_DIR \
+    -USHARE_INSTALL_PREFIX \
+    -ULIB_SUFFIX \
+    -DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
+    -DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+    -DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+    -DCMAKE_INSTALL_LIBDIR="/opt/ros/%{ros_distro}/lib" \
+    -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+    -DBUILD_TESTING=OFF \
+%endif
+    ..
+
+%make_build
+
+%install
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it.  It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# Look for a Makefile target with a name indicating that it runs tests
+TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
+if [ -n "$TEST_TARGET" ]; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it.  It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+CTEST_OUTPUT_ON_FAILURE=1 \
+    %make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Jorge Nicho jrgnichodevel@gmail.com - 0.1.2-1
+- Autogenerated by ros-porting-tools
-- 
cgit v1.2.3