From 1f95f901a1e51085ddd0e9c03c928f838751c22c Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 10 Jan 2025 08:40:05 +0000
Subject: automatic import of perl-IPC-SharedCache

---
 perl-IPC-SharedCache.spec | 74 +++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 74 insertions(+)
 create mode 100644 perl-IPC-SharedCache.spec

(limited to 'perl-IPC-SharedCache.spec')

diff --git a/perl-IPC-SharedCache.spec b/perl-IPC-SharedCache.spec
new file mode 100644
index 0000000..8e48406
--- /dev/null
+++ b/perl-IPC-SharedCache.spec
@@ -0,0 +1,74 @@
+Name:           perl-IPC-SharedCache
+Version:        1.3
+Release:        1
+Summary:        Perl module to manage a cache in SysV IPC shared memory
+License:        GPLv2+
+URL:            https://metacpan.org/release/IPC-SharedCache
+Source0:        https://cpan.metacpan.org/modules/by-module/IPC/IPC-SharedCache-%{version}.tar.gz
+Patch0:         IPC-SharedCache-1.3-test.patch
+BuildArch:      noarch
+# Build
+BuildRequires:  coreutils
+BuildRequires:  findutils
+BuildRequires:  make
+BuildRequires:  perl-generators
+BuildRequires:  perl-interpreter
+BuildRequires:  perl(ExtUtils::MakeMaker)
+# Module
+BuildRequires:  perl(Carp)
+BuildRequires:  perl(integer)
+BuildRequires:  perl(IPC::ShareLite) >= 0.06
+BuildRequires:  perl(Storable)
+BuildRequires:  perl(strict)
+BuildRequires:  perl(vars)
+# Test Suite
+# (no additional dependencies)
+# Dependencies
+Requires:       perl(IPC::ShareLite) >= 0.06
+
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(IPC::ShareLite\\)$
+
+%description
+This module provides a shared memory cache accessed as a tied hash.
+Shared memory is an area of memory that is available to all processes.
+It is accessed by choosing a key, the ipc_key argument to tie.  Every
+process that accesses shared memory with the same key gets access to
+the same region of memory.  In some ways it resembles a file system,
+but it is not hierarchical and it is resident in memory.  This makes
+it harder to use than a filesystem but much faster.  The data in
+shared memory persists until the machine is rebooted or it is
+explicitly deleted.
+
+
+%prep
+%setup -q -n IPC-SharedCache-%{version}
+
+# Debian patch for tests, which fixes problem of HTML::Template
+%patch -P0 -p1
+
+%build
+perl Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
+
+
+%install
+make pure_install DESTDIR=%{buildroot}
+find %{buildroot} -type f -name .packlist -delete
+%{_fixperms} -c %{buildroot}
+
+
+%check
+make test
+
+
+
+%files
+%license LICENSE
+%doc ANNOUNCE Changes README
+%{perl_vendorlib}/IPC/
+%{_mandir}/man3/IPC::SharedCache.3*
+
+
+%changelog
+* Mon Nov 04 2024 fu-shanqing<dev01203@linx-info.com> - 1.3-1
+- init package
-- 
cgit v1.2.3