summaryrefslogtreecommitdiff
path: root/golang.spec
diff options
context:
space:
mode:
Diffstat (limited to 'golang.spec')
-rw-r--r--golang.spec444
1 files changed, 444 insertions, 0 deletions
diff --git a/golang.spec b/golang.spec
new file mode 100644
index 0000000..2af841f
--- /dev/null
+++ b/golang.spec
@@ -0,0 +1,444 @@
+%global debug_package %{nil}
+%global _binaries_in_noarch_packages_terminate_build 0
+%global golibdir %{_libdir}/golang
+%global goroot /usr/lib/%{name}
+%global go_api 1.20
+%global go_version 1.20
+%global __spec_install_post /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot /usr/lib/rpm/brp-compress
+%global __requires_exclude_from ^(%{_datadir}|/usr/lib)/%{name}/(doc|src)/.*$
+%global __strip /bin/true
+%global vendor %{?_vendor:%{_vendor}}%{!?_vendor:openEuler}
+%define _use_internal_dependency_generator 0
+%define __find_requires %{nil}
+
+%bcond_with bootstrap
+%ifarch x86_64 aarch64 riscv64 loongarch64 ppc64le
+%bcond_without ignore_tests
+%else
+%bcond_with ignore_tests
+%endif
+
+%ifarch x86_64 aarch64 riscv64 loongarch64 ppc64le
+%global external_linker 1
+%else
+%global external_linker 0
+%endif
+
+%ifarch x86_64 aarch64 riscv64 loongarch64 ppc64le
+%global cgo_enabled 1
+%else
+%global cgo_enabled 0
+%endif
+
+%if %{with bootstrap}
+%global golang_bootstrap 0
+%else
+%global golang_bootstrap 1
+%endif
+
+%if %{with ignore_tests}
+%global fail_on_tests 0
+%else
+%global fail_on_tests 1
+%endif
+
+%global shared 0
+
+# Pre build std lib with -race enabled
+# Disabled due to 1.20 new cache usage, see 1.20 upstream release notes
+%global race 0
+
+%ifarch x86_64
+%global gohostarch amd64
+%endif
+%ifarch aarch64
+%global gohostarch arm64
+%endif
+%ifarch riscv64
+%global gohostarch riscv64
+%endif
+%ifarch ppc64le
+%global gohostarch ppc64le
+%endif
+%ifarch loongarch64
+%global gohostarch loong64
+%endif
+
+Name: golang
+Version: 1.21.4
+Release: 17
+Summary: The Go Programming Language
+License: BSD and Public Domain
+URL: https://golang.org/
+Source0: https://dl.google.com/go/go%{version}.src.tar.gz
+
+%if !%{golang_bootstrap}
+BuildRequires: gcc-go >= 5
+%else
+BuildRequires: golang > 1.4
+%endif
+BuildRequires: hostname
+# for tests
+BuildRequires: pcre-devel, glibc-static, perl-interpreter, procps-ng
+
+Provides: go = %{version}-%{release}
+Requires: %{name}-devel = %{version}-%{release}
+
+Obsoletes: %{name}-pkg-bin-linux-386 < 1.4.99
+Obsoletes: %{name}-pkg-bin-linux-amd64 < 1.4.99
+Obsoletes: %{name}-pkg-bin-linux-arm < 1.4.99
+Obsoletes: %{name}-pkg-linux-386 < 1.4.99
+Obsoletes: %{name}-pkg-linux-amd64 < 1.4.99
+Obsoletes: %{name}-pkg-linux-arm < 1.4.99
+Obsoletes: %{name}-vet < 0-12.1
+Obsoletes: %{name}-cover < 0-12.1
+
+Requires(post): %{_sbindir}/update-alternatives
+Requires(postun): %{_sbindir}/update-alternatives
+Recommends: glibc gcc git subversion
+
+# Bundled/Vendored provides generated by bundled-deps.sh based on the in tree module data
+# - in version filed substituted with . per versioning guidelines
+Provides: bundled(golang(github.com/google/pprof)) = 0.0.0.20221118152302.e6195bd50e26
+Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = 0.0.0.20220319035150.800ac71e25c2
+Provides: bundled(golang(golang.org/x/arch)) = 0.4.0
+Provides: bundled(golang(golang.org/x/crypto)) = 0.11.1.0.20230711161743.2e82bdd1719d
+Provides: bundled(golang(golang.org/x/mod)) = 0.12.0
+Provides: bundled(golang(golang.org/x/net)) = 0.12.1.0.20231027154334.5ca955b1789c
+Provides: bundled(golang(golang.org/x/sync)) = 0.3.0
+Provides: bundled(golang(golang.org/x/sys)) = 0.10.0
+Provides: bundled(golang(golang.org/x/term)) = 0.10.0
+Provides: bundled(golang(golang.org/x/text)) = 0.11.0
+Provides: bundled(golang(golang.org/x/tools)) = 0.11.1.0.20230712164437.1ca21856af7b
+
+Provides: %{name}-bin = %{version}-%{release}
+Obsoletes: %{name}-bin
+Obsoletes: %{name}-shared
+Obsoletes: %{name}-docs
+Obsoletes: %{name}-data < 1.1.1-4
+Obsoletes: %{name}-vim < 1.4
+Obsoletes: emacs-%{name} < 1.4
+Requires: %{vendor}-rpm-config
+
+Patch6001: backport-0001-release-branch.go1.21-crypto-x509-make-sure-pub-key-.patch
+Patch6002: backport-0002-release-branch.go1.21-html-template-escape-additiona.patch
+Patch6003: backport-0003-release-branch.go1.21-net-textproto-mime-multipart-a.patch
+Patch6004: backport-0004-release-branch.go1.21-net-http-net-http-cookiejar-av.patch
+Patch6005: backport-0005-release-branch.go1.21-net-mail-properly-handle-speci.patch
+Patch6006: backport-0006-Backport-net-http-update-bundled-golang.org-x-net-ht.patch
+Patch6007: backport-0007-Backport-cmd-go-disallow-lto_library-in-LDFLAGS.patch
+
+Patch6008: backport-0008-release-branch.go1.21-net-netip-check-if-address-is-v6.patch
+Patch6009: backport-0009-Backport-cmd-go-internal-vcs-error-out-if-the-reques.patch
+Patch6010: backport-0010-release-branch.go1.21-net-http-limit-chunked-data-ov.patch
+Patch6011: backport-0011-Backport-archive-zip-treat-truncated-EOCDR-comment-a.patch
+Patch6012: backport-0012-net-http-send-body-or-close-connection-on-expect-100.patch
+Patch6013: backport-0013-release-branch.go1.21-net-http-update-bundled-golang.patch
+Patch6014: backport-0014-cmd-compile-handle-constant-pointer-offsets-in-dead-.patch
+Patch6015: backport-0015-release-branch.go1.21-cmd-compile-ensure-pointer-ari.patch
+
+ExclusiveArch: %{golang_arches}
+
+%description
+%{summary}.
+
+%package help
+Summary: Golang compiler helps and manual docs
+Requires: %{name} = %{version}-%{release}
+BuildArch: noarch
+Provides: %{name}-docs = %{version}-%{release}
+Obsoletes: %{name}-docs < %{version}-%{release}
+Provides: %{name}-shared = %{version}-%{release}
+Obsoletes: %{name}-shared < %{version}-%{release}
+
+%description help
+%{summary}.
+
+%package devel
+Summary: Golang compiler devel
+BuildArch: noarch
+Requires: %{name} = %{version}-%{release}
+Provides: %{name}-src = %{version}-%{release}
+Obsoletes: %{name}-src < %{version}-%{release}
+Provides: %{name}-tests = %{version}-%{release}
+Obsoletes: %{name}-tests < %{version}-%{release}
+Provides: %{name}-misc = %{version}-%{release}
+Obsoletes: %{name}-misc < %{version}-%{release}
+Obsoletes: %{name}-race = %{version}-%{release}
+
+%description devel
+%{summary}.
+
+# Workaround old RPM bug of symlink-replaced-with-dir failure
+%pretrans -p <lua>
+for _,d in pairs({"api", "doc", "include", "lib", "src"}) do
+ path = "%{goroot}/" .. d
+ if posix.stat(path, "type") == "link" then
+ os.remove(path)
+ posix.mkdir(path)
+ end
+end
+
+%prep
+%autosetup -n go -p1
+
+%build
+uname -a
+cat /proc/cpuinfo
+cat /proc/meminfo
+
+%if !%{golang_bootstrap}
+export GOROOT_BOOTSTRAP=/
+%else
+export GOROOT_BOOTSTRAP=%{goroot}
+%endif
+
+export GOROOT_FINAL=%{goroot}
+export GOHOSTOS=linux
+export GOHOSTARCH=%{gohostarch}
+
+pushd src
+export CFLAGS="$RPM_OPT_FLAGS"
+export LDFLAGS="$RPM_LD_FLAGS"
+export CC="gcc"
+export CC_FOR_TARGET="gcc"
+export GOOS=linux
+export GOARCH=%{gohostarch}
+%if !%{external_linker}
+export GO_LDFLAGS="-linkmode internal"
+%endif
+%if !%{cgo_enabled}
+export CGO_ENABLED=0
+%endif
+
+%ifarch aarch64
+export GO_LDFLAGS="-s -w"
+%endif
+
+./make.bash --no-clean -v
+popd
+
+%if %{shared}
+GOROOT=$(pwd) PATH=$(pwd)/bin:$PATH go install -buildmode=shared -v -x std
+%endif
+
+%if %{race}
+GOROOT=$(pwd) PATH=$(pwd)/bin:$PATH go install -race -v -x std
+%endif
+
+%install
+rm -rf %{buildroot}
+rm -rf pkg/obj/go-build/*
+
+mkdir -p %{buildroot}%{_bindir}
+mkdir -p %{buildroot}%{goroot}
+
+cp -apv api bin doc lib pkg src misc test go.env VERSION \
+ %{buildroot}%{goroot}
+
+# bz1099206
+find %{buildroot}%{goroot}/src -exec touch -r %{buildroot}%{goroot}/VERSION "{}" \;
+# and level out all the built archives
+touch %{buildroot}%{goroot}/pkg
+find %{buildroot}%{goroot}/pkg -exec touch -r %{buildroot}%{goroot}/pkg "{}" \;
+# generate the spec file ownership of this source tree and packages
+cwd=$(pwd)
+src_list=$cwd/go-src.list
+pkg_list=$cwd/go-pkg.list
+shared_list=$cwd/go-shared.list
+race_list=$cwd/go-race.list
+misc_list=$cwd/go-misc.list
+docs_list=$cwd/go-docs.list
+tests_list=$cwd/go-tests.list
+rm -f $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list $race_list
+touch $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list $race_list
+pushd %{buildroot}%{goroot}
+ find src/ -type d -a \( ! -name testdata -a ! -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $src_list
+ find src/ ! -type d -a \( ! -ipath '*/testdata/*' -a ! -name '*_test.go' \) -printf '%{goroot}/%p\n' >> $src_list
+
+ find bin/ pkg/ -type d -a ! -path '*_dynlink/*' -a ! -path '*_race/*' -printf '%%%dir %{goroot}/%p\n' >> $pkg_list
+ find bin/ pkg/ ! -type d -a ! -path '*_dynlink/*' -a ! -path '*_race/*' -printf '%{goroot}/%p\n' >> $pkg_list
+
+ find doc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $docs_list
+ find doc/ ! -type d -printf '%{goroot}/%p\n' >> $docs_list
+
+ find misc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $misc_list
+ find misc/ ! -type d -printf '%{goroot}/%p\n' >> $misc_list
+
+%if %{shared}
+ mkdir -p %{buildroot}/%{_libdir}/
+ mkdir -p %{buildroot}/%{golibdir}/
+ for file in $(find . -iname "*.so" ); do
+ chmod 755 $file
+ mv $file %{buildroot}/%{golibdir}
+ pushd $(dirname $file)
+ ln -fs %{golibdir}/$(basename $file) $(basename $file)
+ popd
+ echo "%%{goroot}/$file" >> $shared_list
+ echo "%%{golibdir}/$(basename $file)" >> $shared_list
+ done
+
+ find pkg/*_dynlink/ -type d -printf '%%%dir %{goroot}/%p\n' >> $shared_list
+ find pkg/*_dynlink/ ! -type d -printf '%{goroot}/%p\n' >> $shared_list
+%endif
+
+%if %{race}
+
+ find pkg/*_race/ -type d -printf '%%%dir %{goroot}/%p\n' >> $race_list
+ find pkg/*_race/ ! -type d -printf '%{goroot}/%p\n' >> $race_list
+
+%endif
+
+ find test/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
+ find test/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
+ find src/ -type d -a \( -name testdata -o -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $tests_list
+ find src/ ! -type d -a \( -ipath '*/testdata/*' -o -name '*_test.go' \) -printf '%{goroot}/%p\n' >> $tests_list
+ # this is only the zoneinfo.zip
+ find lib/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
+ find lib/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
+popd
+
+rm -rfv %{buildroot}%{goroot}/doc/Makefile
+
+mkdir -p %{buildroot}%{goroot}/bin/linux_%{gohostarch}
+ln -sf %{goroot}/bin/go %{buildroot}%{goroot}/bin/linux_%{gohostarch}/go
+ln -sf %{goroot}/bin/gofmt %{buildroot}%{goroot}/bin/linux_%{gohostarch}/gofmt
+
+mkdir -p %{buildroot}%{gopath}/src/github.com
+mkdir -p %{buildroot}%{gopath}/src/bitbucket.org
+mkdir -p %{buildroot}%{gopath}/src/code.google.com/p
+mkdir -p %{buildroot}%{gopath}/src/golang.org/x
+
+%check
+export GOROOT=$(pwd -P)
+export PATH="$GOROOT"/bin:"$PATH"
+cd src
+
+export CC="gcc"
+export CFLAGS="$RPM_OPT_FLAGS"
+export LDFLAGS="$RPM_LD_FLAGS"
+%if !%{external_linker}
+export GO_LDFLAGS="-linkmode internal"
+%endif
+%if !%{cgo_enabled} || !%{external_linker}
+export CGO_ENABLED=0
+%endif
+
+export GO_TEST_TIMEOUT_SCALE=2
+
+%if %{fail_on_tests}
+echo tests ignored
+%else
+./run.bash --no-rebuild -v -k -run='!(cmd/go|go/build|cmd/internal/testdir|cmd/link|cmd/nm|cmd/cgo/internal/testlife|cmd/cgo/internal/teststdio|cmd/cgo/internal/testerrors|tyepparams|race|flag|cgo_stdio|cgo_life|cgo_errors|test:0_1|api)'
+%endif
+cd ..
+
+%post
+%{_sbindir}/update-alternatives --install %{_bindir}/go \
+ go %{goroot}/bin/go 90 \
+ --slave %{_bindir}/gofmt gofmt %{goroot}/bin/gofmt
+
+%preun
+if [ $1 = 0 ]; then
+ %{_sbindir}/update-alternatives --remove go %{goroot}/bin/go
+fi
+
+%if %{shared}
+%files -f go-pkg.list -f go-shared.list
+%else
+%files -f go-pkg.list
+%endif
+
+%doc LICENSE PATENTS
+%doc %{goroot}/VERSION
+%dir %{goroot}/doc
+%doc %{goroot}/doc/*
+%dir %{goroot}
+%exclude %{goroot}/src/
+%exclude %{goroot}/doc/
+%exclude %{goroot}/misc/
+%exclude %{goroot}/test/
+%exclude %{goroot}/lib/
+%{goroot}/*
+%dir %{gopath}
+%dir %{gopath}/src
+%dir %{gopath}/src/github.com/
+%dir %{gopath}/src/bitbucket.org/
+%dir %{gopath}/src/code.google.com/
+%dir %{gopath}/src/code.google.com/p/
+%dir %{gopath}/src/golang.org
+%dir %{gopath}/src/golang.org/x
+
+%files help -f go-docs.list
+
+%files devel -f go-tests.list -f go-misc.list -f go-src.list
+
+%changelog
+* Mon Jul 30 2024 jingxiaolu <lujingxiao@huawei.com> - 1.21.4-17
+- cmd/compile: ensure pointer arithmetic happens after the nil check
+
+* Mon Jul 30 2024 jingxiaolu <lujingxiao@huawei.com> - 1.21.4-16
+- cmd/compile: handle constant pointer offsets in dead store elimination
+
+* Mon Jul 29 2024 EulerOSWander <314264452@qq.com> - 1.21.4-15
+- fix send correct lastStreamID in stream-caused GOAWAY
+
+* Wed Jul 03 2024 kywqs <weiqingsong@kylinos.cn.com> - 1.21.4-14
+- fix CVE-2024-24791
+
+* Sun Jun 23 2024 hanchao <hanchao63@huawei.com> - 1.21.4-13
+- Type:CVE
+- CVE:CVE-2023-39326,CVE-2024-24789
+- SUG:NA
+- DESC:fix CVE-2023-39326,CVE-2024-24789
+
+* Fri Jun 21 2024 EulerOSWander <314264452@qq.com> - 1.21.4-12
+- fix CVE-2023-45285
+
+* Thu May 23 2024 EulerOSWander <314264452@qq.com> - 1.21.4-11
+- fix CVE-2024-24787
+
+* Thu Jun 13 2024 Zhao Mengmeng <zhaomengmeng@kylinos.cn> - 1.21.4-10
+- fix CVE-2024-24790
+
+* Tue Jun 11 2024 chenguoqi <chenguoqi@loongson.cn> - 1.21.4-9
+- Fix missing go.env file
+
+* Thu Apr 18 2024 Huang Yang <huangyang@loongson.cn> - 1.21.4-8
+- enable external_linker and cgo on loongarch64
+
+* Tue Apr 16 2024 hanchao <hanchao63@huawei.com> - 1.21.4-7
+- fix CVE-2023-45288
+
+* Thu Mar 28 2024 hanchao <hanchao63@huawei.com> - 1.21.4-6
+- fix CVE-2024-24784
+
+* Thu Mar 28 2024 hanchao <hanchao63@huawei.com> - 1.21.4-5
+- enabling the patches
+
+* Tue Mar 26 2024 Wenlong Zhang <zhangwenlong@loongson.cn> - 1.21.4-4
+- fix build error for loongarch64
+
+* Fri Mar 15 2024 hanchao <hanchao63@huawei.com> - 1.21.4-3
+- fix CVE-2024-24783,CVE-2024-24785,CVE-2023-45290,CVE-2023-45289
+
+* Wed Dec 13 2023 jiahua.yu <jiahua.yu@shingroup.cn> - 1.21.4-2
+- init support for arch ppc64le
+
+* Tue Dec 5 2023 hanchao <hanchao63@huawei.com> - 1.21.4-1
+- upgrade to 1.21.4
+
+* Thu Aug 24 2023 wanglimin <wanglimin@xfusion.com> - 1.20.7-2
+- permit invalid host header for docker
+
+* Mon Aug 7 2023 Funda Wang <fundawang@yeah.net> - 1.20.7-1
+- New version 1.20.7
+
+* Sun Jul 30 2023 Funda Wang <fundawang@yeah.net> - 1.20.5-3
+- Use local proxy and sumdb for speed up
+
+* Tue Jul 11 2023 hanchao <sunchendong@xfusion.com> - 1.20.5-2
+- fix CVE-2023-29406
+
+* Wed Jun 21 2023 hanchao <hanchao63@huawei.com> - 1.20.5-1
+- upgrade to 1.20.5