summaryrefslogtreecommitdiff
path: root/php.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-19 14:02:45 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-19 14:02:45 +0000
commit30fdeed892099f518733b690d57754dc915ea2e0 (patch)
tree28de34f9a692731d7cc22d2d435c77fcee1c41f9 /php.spec
parent5686441efe4aab7ef4bfd33a07301aa6c216819f (diff)
automatic import of php
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec28
1 files changed, 8 insertions, 20 deletions
diff --git a/php.spec b/php.spec
index 5320664..9d6ea70 100644
--- a/php.spec
+++ b/php.spec
@@ -548,16 +548,6 @@ The php-pspell package contains a dynamic shared object that will add
support for using the pspell library to PHP.
%endif
-%package recode
-Summary: A module for PHP applications for using the recode library
-License: PHP
-Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: recode-devel
-
-%description recode
-The php-recode package contains a dynamic shared object that will add
-support for using the recode library to PHP.
-
%package intl
Summary: Internationalization extension for PHP applications
License: PHP
@@ -746,9 +736,9 @@ build --libdir=%{_libdir}/php --enable-pcntl --enable-opcache --enable-opcache-f
%endif
--enable-mbstring=shared --with-onig=%{_prefix} --enable-mbregex \
%if %{with_libgd}
- --with-gd=shared,%{_prefix} \
+ --enable-gd=shared --with-external-gd \
%else
- --with-gd=shared \
+ --enable-gd=shared --with-webp --with-jpeg --with-xpm --with-freetype \
%endif
--with-gmp=shared --enable-calendar=shared --enable-bcmath=shared --with-bz2=shared --enable-ctype=shared \
--enable-dba=shared --with-db4=%{_prefix} --with-tcadb=%{_prefix} \
@@ -794,7 +784,7 @@ build --libdir=%{_libdir}/php --enable-pcntl --enable-opcache --enable-opcache-f
%else
--without-sodium \
%endif
- --enable-intl=shared --with-icu-dir=%{_prefix} --with-enchant=shared,%{_prefix} --with-recode=shared,%{_prefix}
+ --enable-intl=shared --with-icu-dir=%{_prefix} --with-enchant=shared,%{_prefix}
popd
without_shared="--without-gd --disable-dom --disable-dba --without-unixODBC --disable-opcache --disable-json \
@@ -830,9 +820,9 @@ build --includedir=%{_includedir}/php-zts --libdir=%{_libdir}/php-zts --enable-m
%endif
--enable-mbstring=shared --with-onig=%{_prefix} --enable-mbregex \
%if %{with_libgd}
- --with-gd=shared,%{_prefix} \
+ --enable-gd=shared --with-external-gd \
%else
- --with-gd=shared \
+ --enable-gd=shared --with-webp --with-jpeg --with-xpm --with-freetype \
%endif
--with-gmp=shared --enable-calendar=shared --enable-bcmath=shared --with-bz2=shared --enable-ctype=shared \
--enable-dba=shared --with-db4=%{_prefix} --with-tcadb=%{_prefix} \
@@ -878,7 +868,7 @@ build --includedir=%{_includedir}/php-zts --libdir=%{_libdir}/php-zts --enable-m
%else
--without-sodium \
%endif
- --enable-intl=shared --with-icu-dir=%{_prefix} --with-enchant=shared,%{_prefix} --with-recode=shared,%{_prefix}
+ --enable-intl=shared --with-icu-dir=%{_prefix} --with-enchant=shared,%{_prefix}
popd
pushd build-zts
@@ -1002,7 +992,7 @@ for mod in pgsql odbc ldap snmp xmlrpc \
%if %{with_sodium}
sodium \
%endif
- posix shmop sysvshm sysvsem sysvmsg recode xml \
+ posix shmop sysvshm sysvsem sysvmsg xml \
; do
case $mod in
opcache)
@@ -1204,7 +1194,6 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
%endif
%files soap -f files.soap
%files bcmath -f files.bcmath
-%license libbcmath_COPYING
%files gmp -f files.gmp
%files dba -f files.dba
%files pdo -f files.pdo
@@ -1217,7 +1206,6 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
%endif
%files intl -f files.intl
%files process -f files.process
-%files recode -f files.recode
%if %{with_firebird}
%files interbase -f files.interbase
%endif
@@ -1237,7 +1225,7 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
%endif
%files help
-%doc CODING_STANDARDS CREDITS EXTENSIONS NEWS README* sapi/cgi/README* sapi/cli/README sapi/phpdbg/{README.md,CREDITS}
+%doc EXTENSIONS NEWS README* sapi/phpdbg/{README.md,CREDITS}
%doc php-fpm.conf.default www.conf.default php.ini-*
%{_mandir}/*