summaryrefslogtreecommitdiff
path: root/cmake.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cmake.spec')
-rw-r--r--cmake.spec35
1 files changed, 17 insertions, 18 deletions
diff --git a/cmake.spec b/cmake.spec
index 855bcab..4c1cb27 100644
--- a/cmake.spec
+++ b/cmake.spec
@@ -2,17 +2,10 @@
%bcond_without ncurses
%bcond_without X11_test
-%ifarch aarch64_ilp32
-%bcond_with cmake_gui
-%bcond_with emacs
-%bcond_without bootstrap
-%bcond_with sphinx
-%else
%bcond_without cmake_gui
%bcond_without emacs
%bcond_with bootstrap
%bcond_without sphinx
-%endif
# Do not build non-lto objects to reduce build time significantly.
%global build_cflags %(echo '%{build_cflags}' | sed -e 's!-ffat-lto-objects!-fno-fat-lto-objects!g')
@@ -28,7 +21,7 @@
Name: cmake
Version: 3.27.9
%global major_version %(echo %{version} | awk -F. '{print $1}')
-Release: 8
+Release: 10
Summary: Cross-platform make system
License: BSD-3-Clause AND MIT-open-group AND Zlib
URL: http://www.cmake.org
@@ -39,14 +32,8 @@ Source3: cmake.attr
Source4: cmake.prov
Source5: cmake.req
Patch0: cmake-findruby.patch
-%ifarch sw_64
-Patch1: cmake-3.22.0-sw.patch
-%endif
-Patch2: cmake-3.27.9-fix-cxx-standard-check-issue.patch
-
-%ifarch aarch64_ilp32
-Patch6000: backport-cmake-aarch64-ilp32-support.patch
-%endif
+Patch1: cmake-3.27.9-fix-cxx-standard-check-issue.patch
+Patch2: cmake-3.22.0-sw.patch
BuildRequires: coreutils findutils gcc-c++ gcc-gfortran sed
@@ -139,7 +126,12 @@ BuildArch: noarch
Documentation for cmake.
%prep
-%autosetup -n cmake-%{version}%{?versuf} -p 1
+%setup -n cmake-%{version}%{?versuf}
+%patch 0 -p1
+%patch 1 -p1
+%ifarch sw_64
+%patch 2 -p1
+%endif
echo '#!%{__python3}' > %{name}.prov
echo '#!%{__python3}' > %{name}.req
@@ -316,9 +308,16 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%exclude %{_pkgdocdir}/Copyright.txt
%changelog
-* Wed Nov 06 2024 Funda Wang <fundawang@yeah.net> - 3.27.9-8
+* Sun Jan 26 2025 fuanan <fuanan3@h-partners.com> - 3.27.9-10
+- No longer support aarch64_ilp32 compilation
+
+* Thu Jan 23 2025 Funda Wang <fundawang@yeah.net> - 3.27.9-9
- default to out-of-source build
+* Thu Jan 23 2025 fuanan <fuanan3@h-partners.com> - 3.27.9-8
+- remove the architecture judgment in the patches section;
+- include all patches in the source package.
+
* Tue Nov 05 2024 Funda Wang <fundawang@yeah.net> - 3.27.9-7
- change __cmake_builddir definition based on numeric comparision
- force define source and binary directory