summaryrefslogtreecommitdiff
path: root/lasso.spec
diff options
context:
space:
mode:
Diffstat (limited to 'lasso.spec')
-rw-r--r--lasso.spec51
1 files changed, 30 insertions, 21 deletions
diff --git a/lasso.spec b/lasso.spec
index fd53590..678bea7 100644
--- a/lasso.spec
+++ b/lasso.spec
@@ -1,11 +1,12 @@
Name: lasso
Version: 2.8.2
-Release: 3
+Release: 2
Summary: Liberty Alliance Single Sign On
-License: GPL-2.0-or-later
+License: GPLv2+
URL: http://lasso.entrouvert.org/
Source: http://dev.entrouvert.org/lasso/lasso-%{version}.tar.gz
-Patch6001: lasso-HEAD.patch
+Patch0001: Fix-build-failure-due-to-automake-upgrade.patch
+Patch0002: lasso-perl-bindings-ldflags.patch
Requires: xmlsec1 >= 1.2.25-4
BuildRequires: autoconf automake check-devel glib2-devel gtk-doc libtool
@@ -14,7 +15,7 @@ BuildRequires: xmlsec1-openssl-devel >= 1.2.25-4 zlib-devel
BuildRequires: perl(ExtUtils::MakeMaker) perl(strict) perl(Error)
BuildRequires: perl-devel perl-generators perl(XSLoader) perl(warnings)
BuildRequires: perl(Test::More) python3 python3-devel
-BuildRequires: python3-lxml libtool-ltdl-devel
+BuildRequires: python3-lxml python3-six libtool-ltdl-devel
Obsoletes: java-lasso < %{version}-%{release}
@@ -32,6 +33,7 @@ and static libraries for lasso.
%package -n perl-lasso
Summary: Liberty Alliance Single Sign On (lasso) Perl bindings
+Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Requires: lasso = %{version}-%{release}
%description -n perl-lasso
The package provide Perl language bindings for the lasso
@@ -46,7 +48,11 @@ Requires: python3 lasso = %{version}-%{release}
The package provide Python language bindings for the lasso
(Liberty Alliance Single Sign On)library.
-%package_help
+%package help
+Summary: Help document for the lasso packages
+
+%description help
+Help document for the lasso packages
%prep
%autosetup -n lasso-%{version} -p1
@@ -55,42 +61,45 @@ sed -i -E -e '/^#![[:blank:]]*(\/usr\/bin\/env[[:blank:]]+python[^3]?\>) \
|(/usr/bin/env[[:blank:]]+python[^3]?)' *`
%build
-autoreconf -fi
+./autogen.sh
%configure --enable-php5=no --with-python=%{__python3}
-%make_build
+%make_build CFLAGS="%{optflags}"
%check
-%make_build check CK_TIMEOUT_MULTIPLIER=10
+make check CK_TIMEOUT_MULTIPLIER=10
%install
-%make_install
-%delete_la_and_a
-
-rm -fr %{buildroot}%{_datadir}/doc
+%make_install exec_prefix=%{_prefix} DESTDIR=%{buildroot}
+find %{buildroot} -type f -name '*.la' -exec rm -f {} \;
+find %{buildroot} -type f -name '*.a' -exec rm -f {} \;
+find %{buildroot} \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
+find %{buildroot}/usr/lib*/perl5 -type f -print |
+ sed "s@^%{buildroot}@@g" > lasso-perl-filelist
+if [ "$(cat lasso-perl-filelist)X" = "X" ] ; then
+ echo "ERROR: EMPTY FILE LIST"
+ exit -1
+fi
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
%files
%license COPYING
%{_libdir}/liblasso.so.3*
+%exclude %{_defaultdocdir}/lasso
%files devel
%{_includedir}/lasso
-%{_libdir}/liblasso.so
-%{_libdir}/pkgconfig/lasso.pc
+%{_libdir}/{liblasso.so,pkgconfig/lasso.pc}
-%files -n perl-lasso
-%{perl_vendorarch}/Lasso.pm
-%{perl_vendorarch}/auto/Lasso
+%files -n perl-lasso -f lasso-perl-filelist
%files -n python3-lasso
-%{python3_sitearch}/*
+%{python3_sitearch}/{lasso.py*,_lasso.so,__pycache__/*}
%files help
%doc AUTHORS NEWS README
%changelog
-* Fri Oct 25 2024 Funda Wang <fundawang@yeah.net> - 2.8.2-3
-- fix build with xmlsec 1.3 and libxml 2.12
-
* Mon Jul 22 2024 yuanlipeng <yuanlipeng2@huawei.com> - 2.8.2-2
- Fix build failure due to automake upgrade