summaryrefslogtreecommitdiff
path: root/libsoup3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libsoup3.spec')
-rw-r--r--libsoup3.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/libsoup3.spec b/libsoup3.spec
new file mode 100644
index 0000000..1dd4d8f
--- /dev/null
+++ b/libsoup3.spec
@@ -0,0 +1,112 @@
+%global glib2_version 2.69.1
+
+%bcond_without sysprof
+
+Name: libsoup3
+Version: 3.4.4
+Release: 5
+Summary: Soup, an HTTP library implementation
+License: LGPL-2.0-or-later
+URL: https://wiki.gnome.org/Projects/libsoup
+Source0: https://download.gnome.org/sources/libsoup/3.4/libsoup-%{version}.tar.xz
+
+Patch0001: 0001-websocket-process-the-frame-as-soon-as-we-read-data.patch
+Patch0002: backport-CVE-2024-52530.patch
+
+BuildRequires: gcc gettext vala krb5-devel samba-winbind-clients
+BuildRequires: meson >= 0.54
+BuildRequires: pkgconfig(gio-2.0) >= %{glib2_version}
+BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib2_version}
+BuildRequires: pkgconfig(glib-2.0) >= %{glib2_version}
+BuildRequires: pkgconfig(gmodule-2.0) >= %{glib2_version}
+BuildRequires: pkgconfig(gobject-2.0) >= %{glib2_version}
+BuildRequires: pkgconfig(libbrotlidec)
+BuildRequires: pkgconfig(libnghttp2)
+BuildRequires: pkgconfig(libpsl) >= 0.20
+BuildRequires: pkgconfig(sqlite3)
+BuildRequires: pkgconfig(zlib)
+BuildRequires: gi-docgen >= 2021.1
+BuildRequires: glib-networking
+%if %{with sysprof}
+BuildRequires: pkgconfig(sysprof-capture-4)
+%endif
+
+Recommends: glib-networking >= %{glib2_version}
+
+%description
+Libsoup is an HTTP library implementation in C. It was originally part
+of a SOAP (Simple Object Access Protocol) implementation called Soup, but
+the SOAP and non-SOAP parts have now been split into separate packages.
+
+libsoup uses the Glib main loop and is designed to work well with GTK
+applications. This enables GNOME applications to access HTTP servers
+on the network in a completely asynchronous fashion, very similar to
+the Gtk+ programming model (a synchronous operation mode is also
+supported for those who want it), but the SOAP parts were removed
+long ago.
+
+%package devel
+Summary: Header files for the Soup library
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+Libsoup is an HTTP library implementation in C. This package allows
+you to develop applications that use the libsoup library.
+
+%package_help
+
+%prep
+%autosetup -p1 -n libsoup-%{version}
+
+%build
+%meson -Ddocs=enabled -Dtests=false -Dautobahn=disabled -Dpkcs11_tests=disabled -Dsysprof=%{?with_sysprof:enabled}%{?!with_sysprof:disabled}
+%meson_build
+
+%install
+%meson_install
+install -m 644 -D tests/libsoup.supp %{buildroot}%{_datadir}/libsoup-3.0/libsoup.supp
+
+%find_lang libsoup-3.0
+
+%files -f libsoup-3.0.lang
+%license COPYING
+%{_libdir}/libsoup-3.0.so.0*
+%{_libdir}/girepository-1.0/Soup*3.0.typelib
+
+%files devel
+%{_includedir}/libsoup-3.0
+%{_libdir}/libsoup-3.0.so
+%{_libdir}/pkgconfig/*.pc
+%{_datadir}/gir-1.0/Soup*3.0.gir
+%{_datadir}/vala/vapi/libsoup-3.0.deps
+%{_datadir}/vala/vapi/libsoup-3.0.vapi
+%{_datadir}/libsoup-3.0/libsoup.supp
+
+%files help
+%doc README NEWS AUTHORS
+%{_datadir}/doc
+
+%changelog
+* Fri Nov 22 2024 Funda Wang <fundawang@yeah.net> - 3.4.4-5
+- enable sysprof feature by default
+
+* Fri Nov 22 2024 Han Jinpeng <hanjinpeng@kylinos.cn> - 3.4.4-4
+- Type:CVE
+- ID:CVE-2024-52530
+- SUG:NA
+- DESC: fix CVE-2024-52530
+
+* Wed Nov 13 2024 Deyuan Fan <fandeyuan@kylinos.cn> - 3.4.4-3
+- fix CVE-2024-52532
+
+* Fri Oct 25 2024 Funda Wang <fundawang@yeah.net> - 3.4.4-2
+- make sysprof build conditioned
+
+* Fri Nov 17 2023 lwg <liweiganga@uniontech.com> - 3.4.4-1
+- update to version 3.4.4
+
+* Mon Jan 2 2023 lin zhang <lin.zhang@turbolinux.com.cn> - 3.2.2-1
+- Update 3.2.2
+
+* Mon Apr 11 2022 lin zhang <lin.zhang@turbolinux.com.cn> - 3.0.6-1
+- Initial packaging