summaryrefslogtreecommitdiff
path: root/openEuler-rpm-config.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openEuler-rpm-config.spec')
-rw-r--r--openEuler-rpm-config.spec27
1 files changed, 25 insertions, 2 deletions
diff --git a/openEuler-rpm-config.spec b/openEuler-rpm-config.spec
index b721b52..a36338f 100644
--- a/openEuler-rpm-config.spec
+++ b/openEuler-rpm-config.spec
@@ -3,7 +3,7 @@
Name: %{vendor}-rpm-config
Version: 31
-Release: 7
+Release: 12
License: GPL+
Summary: specific rpm configuration files
URL: https://gitee.com/src-openeuler/openEuler-rpm-config
@@ -30,6 +30,7 @@ Source101: macros.forge
Source102: macros.go
Source103: macros.python
Source104: macros.kmp
+Source105: macros.shell-completions
# Dependency generator scripts
Source200: find-requires.ksyms
@@ -46,6 +47,7 @@ Source303: fix-libtool-from-moving-options-after-libs
# Snapshots from http://git.savannah.gnu.org/gitweb/?p=config.git
Source500: config.guess
Source501: config.sub
+Patch0001: 0001-support-sw_64-arch.patch
# BRPs
Source700: brp-chrpath
@@ -56,6 +58,7 @@ Source704: brp-remove-info-dir
Source705: brp-check-elf-files
Source706: brp-strip-lto
Source707: brp-clean-perl-files
+Source708: brp-llvm-compile-lto-elf
# Convenience lua functions
Source800: common.lua
@@ -113,6 +116,10 @@ Requires: %{_bindir}/xargs
Requires: %{_bindir}/chrpath
Requires: %{_bindir}/eu-elfclassify
+# for brp-llvm-compile-lto-elf
+Requires: (llvm if clang)
+Requires: (gawk if clang)
+
Requires: coreutils
# -fstack-clash-protection and -fcf-protection require GCC 8.
@@ -147,7 +154,7 @@ install -p -m 755 -t %{buildroot}%{rpmvdir} find-requires*
install -p -m 755 -t %{buildroot}%{rpmvdir} find-provides*
mkdir -p %{buildroot}%{_rpmconfigdir}/macros.d
-install -p -m 644 -t %{buildroot}%{_rpmconfigdir}/macros.d/ macros.perl macros.python macros.go macros.forge macros.kmp
+install -p -m 644 -t %{buildroot}%{_rpmconfigdir}/macros.d/ macros.perl macros.python macros.go macros.forge macros.kmp macros.shell-completions
mkdir -p %{buildroot}%{_fileattrsdir}
install -p -m 644 -t %{buildroot}%{_fileattrsdir} *.attr
@@ -179,6 +186,22 @@ sed -i "s/@VENDOR@/%{vendor}/g" `grep "@VENDOR@" -rl %{buildroot}%{_rpmconfigdir
%{rpmvdir}/find-requires.ksyms
%changelog
+* Wed Jan 15 2025 luhuaxin <luhuaxin1@huawei.com> - 31-12
+- ima: keep the process of OBS signing same as previous version
+
+* Sun Jan 12 2025 Funda Wang <fundawang@yeah.net> - 31-11
+- support sw_64 arch
+
+* Mon Jan 06 2025 Funda Wang <fundawang@yeah.net> - 31-10
+- add shell completions dir declaration
+
+* Wed Dec 11 2024 Funda Wang <fundawang@yeah.net> - 31-9
+- update py_install_wheel declaration
+
+* Sat Nov 16 2024 Funda Wang <fundawang@yeah.net> - 31-8
+- compile LLVM IR bitcode in object files or static libraries
+ into ELF object code for clang < 18
+
* Sat Oct 26 2024 Funda Wang <fundawang@yeah.net> - 31-7
- remove useless perl .packlist, empty .bs files and
wrongly created perllocal.pod from buildroot