summaryrefslogtreecommitdiff
path: root/python3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python3.spec')
-rw-r--r--python3.spec6
1 files changed, 6 insertions, 0 deletions
diff --git a/python3.spec b/python3.spec
index 1ab4d98..0daa0fc 100644
--- a/python3.spec
+++ b/python3.spec
@@ -187,6 +187,12 @@ rm -r Modules/expat
rm Lib/ensurepip/_bundled/*.whl
rm configure pyconfig.h.in
+export CFLAGS="%{extension_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv -fstack-protector-strong -D_FORTIFY_SOURCE=2 -O2"
+export CFLAGS_NODIST="%{build_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
+export CXXFLAGS="%{extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"
+export CPPFLAGS="$(pkg-config --cflags-only-I libffi)"
+export OPT="%{extension_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
+
%build
autoconf
autoheader