summaryrefslogtreecommitdiff
path: root/qscintilla.spec
diff options
context:
space:
mode:
Diffstat (limited to 'qscintilla.spec')
-rw-r--r--qscintilla.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/qscintilla.spec b/qscintilla.spec
index 87ddbc3..80ad5b4 100644
--- a/qscintilla.spec
+++ b/qscintilla.spec
@@ -78,8 +78,12 @@ pushd Python
--sip=/usr/bin/sip-pyqt5 \
--qsci-incdir=../Qt4Qt5 --qsci-libdir=../Qt4Qt5
cat Makefile
+sed -i \
+ -e 's,(^CXXFLAGS.*),\1 %{build_cxxflags},' \
+ -e 's,(^LFLAGS.*),\1 %{build_ldflags},' \
+ Qsci/Makefile
cat Qsci/Makefile
-%make_build QMAKE_LFLAGS_RELEASE=%{_qt5_ldflags} QMAKE_CXXFLAGS_RELEASE=%{_qt5_cxxflags}
+%make_build
popd
%install