summaryrefslogtreecommitdiff
path: root/git-lfs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'git-lfs.spec')
-rw-r--r--git-lfs.spec69
1 files changed, 69 insertions, 0 deletions
diff --git a/git-lfs.spec b/git-lfs.spec
new file mode 100644
index 0000000..e8f6120
--- /dev/null
+++ b/git-lfs.spec
@@ -0,0 +1,69 @@
+%define debug_package %{nil}
+%bcond_without check
+
+# https://github.com/git-lfs/git-lfs
+Name: git-lfs
+Version: 3.6.1
+Release: 1
+Summary: Git extension for versioning large files
+
+License: MIT and BSD and Apache-2.0 and MPL-2.0
+URL: https://git-lfs.github.io/
+Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-v%{version}.tar.gz
+Source1: vendor.tar.gz
+Patch6000: 0001-use-vendor-dir-for-build.patch
+
+%if %{with check}
+# Tests
+BuildRequires: perl-Digest-SHA
+BuildRequires: perl-Test-Harness
+# Tests require full git suite, but not generally needed.
+BuildRequires: git >= 1.8.5
+%endif
+BuildRequires: golang, tar, which
+
+Requires: git-core >= 1.8.5
+
+%description
+Git Large File Storage (LFS) replaces large files such as audio samples,
+videos, datasets, and graphics with text pointers inside Git, while
+storing the file contents on a remote server.
+
+
+%prep
+%autosetup -p0 -n %{name}-%{version} -a 1
+
+cd ..
+mv %{name}-%{version} %{name}
+mkdir -p %{name}-%{version}/src/github.com/git-lfs
+mv %{name} %{name}-%{version}/src/github.com/git-lfs/
+
+
+%build
+pushd src/github.com/git-lfs/%{name}
+make
+popd
+# BaseOS is not support rubygem-ronn/ronn, ignore generate man pages
+
+
+%install
+install -Dpm0755 src/github.com/git-lfs/git-lfs/bin/git-lfs %{buildroot}%{_bindir}/%{name}
+
+
+%files
+%{_bindir}/%{name}
+
+
+%changelog
+* Sun Jan 19 2025 Funda Wang <fundawang@yeah.net> - 3.6.1-1
+- Upgrade to 3.6.1
+ - fix CVE-2024-53263: Git LFS permits retrieval of credentials via crafted HTTP URLs
+
+* Tue Jan 14 2025 Xinwei Hu <shinwell_hu@openeuler.sh> - 3.6.0-1
+- Upgrade to 3.6.0
+ - Support multi-stage authentication with Git credential helpers and relative worktree paths
+ - New object transfer batch size configuration option
+ - More POSIX-compliant hook scripts
+
+* Tue Jul 12 2022 zhoukang <gameoverboss@163.com> - 3.2.0-1
+- Initial package