summaryrefslogtreecommitdiff
path: root/python-importlib-resources.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-importlib-resources.spec')
-rw-r--r--python-importlib-resources.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-importlib-resources.spec b/python-importlib-resources.spec
new file mode 100644
index 0000000..31f0b1a
--- /dev/null
+++ b/python-importlib-resources.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-importlib-resources
+Version: 6.0.0
+Release: 1
+Summary: Read resources from Python packages
+License: Apache-2.0
+URL: https://github.com/python/importlib_resources
+Source0: https://files.pythonhosted.org/packages/78/1f/65a619c18b0ecd55ac165c7ed119c846051991d01c2cfc0ff7818e4573f0/importlib_resources-6.0.0.tar.gz#/%{name}-%{version}.tar.gz
+BuildArch: noarch
+Requires: python3-zipp
+Requires: python3-sphinx
+
+%description
+Importlib_resources is a backport of Python standard library.
+
+%package -n python3-importlib-resources
+Summary: Read resources from Python packages
+Provides: python-importlib-resources
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-toml
+BuildRequires: python3-wheel
+
+%description -n python3-importlib-resources
+Importlib_resources is a backport of Python standard library.
+
+%package help
+Summary: Development documents and examples for importlib-resources
+Provides: python3-importlib-resources-doc
+%description help
+Importlib_resources is a backport of Python standard library.
+
+%prep
+%autosetup -n importlib_resources-%{version} -p1
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install importlib_resources==%{version}
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%check
+%{__python3} -m unittest
+
+%files -n python3-importlib-resources -f filelist.lst
+%dir %{python3_sitelib}/*
+%{python3_sitelib}/importlib_resources
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Jan 22 2024 menma <1316818279@qq.com> - 0.9.5-1
+- Package init