summaryrefslogtreecommitdiff
path: root/plasma-drkonqi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'plasma-drkonqi.spec')
-rw-r--r--plasma-drkonqi.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/plasma-drkonqi.spec b/plasma-drkonqi.spec
new file mode 100644
index 0000000..620d86a
--- /dev/null
+++ b/plasma-drkonqi.spec
@@ -0,0 +1,93 @@
+%undefine __cmake_in_source_build
+
+%global base_name drkonqi
+
+Name: plasma-drkonqi
+Summary: DrKonqi crash handler for KF5/Plasma5
+Version: 5.23.4
+Release: 1
+
+License: GPLv2+
+URL: https://cgit.kde.org/%{base_name}.git
+
+%global revision %(echo %{version} | cut -d. -f3)
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+Source0: http://download.kde.org/%{stable}/plasma/%{version}/%{base_name}-%{version}.tar.xz
+
+Patch52: drkonqi-installdbgsymbols.patch
+
+BuildRequires: extra-cmake-modules
+BuildRequires: kf5-rpm-macros
+BuildRequires: qt5-qtbase-devel
+
+BuildRequires: cmake(KF5CoreAddons)
+BuildRequires: cmake(KF5I18n)
+BuildRequires: cmake(KF5Notifications)
+BuildRequires: cmake(KF5Service)
+BuildRequires: cmake(KF5ConfigWidgets)
+BuildRequires: cmake(KF5JobWidgets)
+BuildRequires: cmake(KF5KIO)
+BuildRequires: cmake(KF5Crash)
+BuildRequires: cmake(KF5XmlRpcClient)
+BuildRequires: cmake(KF5Wallet)
+BuildRequires: cmake(KF5WindowSystem)
+BuildRequires: cmake(KF5IdleTime)
+BuildRequires: cmake(KF5SyntaxHighlighting)
+BuildRequires: cmake(Qt5X11Extras)
+
+Obsoletes: plasma-workspace-drkonqi < 5.10.95
+Provides: plasma-workspace-drkonqi = %{version}-%{release}
+
+Requires: (dnf-command(debuginfo-install) if dnf)
+Requires: konsole5
+Requires: polkit
+
+Requires(post): policycoreutils
+
+%description
+%{summary}
+
+
+%prep
+%setup -q -n %{base_name}-%{version}
+
+%patch52 -p1 -b .installdgbsymbols
+
+%build
+mkdir %{_target_platform}
+pushd %{_target_platform}
+%{cmake_kf5} ..
+popd
+%make_build -C %{_target_platform}
+
+%install
+make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
+
+install -p -D -m755 src/doc/examples/installdbgsymbols_fedora.sh \
+ %{buildroot}%{_libexecdir}/installdbgsymbols.sh
+
+%find_lang all --with-html --with-qt --all-name
+grep drkonqi5.mo all.lang > plasma-drkonqi.lang
+
+%post
+if [ -z "$KDE_DEBUG" ] ; then
+if [ "`getsebool deny_ptrace 2>/dev/null`" == 'deny_ptrace --> on' ] ; then
+ setsebool -P deny_ptrace off &> /dev/null || :
+fi
+fi
+
+%files -f plasma-drkonqi.lang
+%license LICENSES/*
+%{_libexecdir}/drkonqi
+%{_libexecdir}/installdbgsymbols.sh
+%{_kf5_datadir}/drkonqi/
+%{_kf5_datadir}/applications/org.kde.*.desktop
+%{_kf5_datadir}/qlogging-categories5/drkonqi.categories
+
+%changelog
+* Tue Jul 19 2022 misaka00251 <misaka00251@misakanet.cn> - 5.23.4-1
+- Init package (Thanks to fedora team)