summaryrefslogtreecommitdiff
path: root/python-cccolutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cccolutils.spec')
-rw-r--r--python-cccolutils.spec65
1 files changed, 65 insertions, 0 deletions
diff --git a/python-cccolutils.spec b/python-cccolutils.spec
new file mode 100644
index 0000000..8a1b7b7
--- /dev/null
+++ b/python-cccolutils.spec
@@ -0,0 +1,65 @@
+%global _empty_manifest_terminate_build 0
+Name: python-CCColUtils
+Version: 1.5
+Release: 2
+Summary: Kerberos5 Credential Cache Collection Utilities
+License: GPLv2+
+URL: https://pagure.io/cccolutils
+Source0: CCColUtils-1.5.tar.gz
+
+%description
+%{summary}.
+
+
+%package -n python3-CCColUtils
+Summary: Kerberos5 Credential Cache Collection Utilities
+Provides: python-CCColUtils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: krb5-devel
+%description -n python3-CCColUtils
+%{summary}.
+
+
+%prep
+%autosetup -n CCColUtils-1.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+
+%check
+%{__python3} setup.py test
+
+%files -n python3-CCColUtils -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%changelog
+* Sat Mar 25 2023 lichaoran <pkwarcraft@hotmail.com> - 1.5-2
+- Fix: no egg-info dir packaged, which led rpm's fileattrs interface
+- will not autogenerate the python3.xdist provides
+
+* Thu Jul 01 2021 jinzig <jinzhiguang@kylinos.cn> - 1.5-1
+- init repo