summaryrefslogtreecommitdiff
path: root/python-XStatic-Patternfly.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-25 09:13:33 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-25 09:13:33 +0000
commit30c9a848d2994b788a200cf4060612bbde777e72 (patch)
treefd223efcb63ed7cd1f5a7a76571c03e77a409c06 /python-XStatic-Patternfly.spec
parent14d300bf5c59b43202306f7bd8496e9f70f422f0 (diff)
automatic import of python-XStatic-Patternfly
Diffstat (limited to 'python-XStatic-Patternfly.spec')
-rw-r--r--python-XStatic-Patternfly.spec22
1 files changed, 15 insertions, 7 deletions
diff --git a/python-XStatic-Patternfly.spec b/python-XStatic-Patternfly.spec
index 6e4a0b9..7251722 100644
--- a/python-XStatic-Patternfly.spec
+++ b/python-XStatic-Patternfly.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: Patternfly 3.21.0 (XStatic packaging standard)
License: Apache v2
URL: https://www.patternfly.org/
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4c/1e/3f69523bf8c2ff8d28d62d87237389ecea32471ab70408d34d14c4c4cb3d/XStatic-Patternfly-3.21.0.1.tar.gz
+Source0: https://files.pythonhosted.org/packages/4c/1e/3f69523bf8c2ff8d28d62d87237389ecea32471ab70408d34d14c4c4cb3d/XStatic-Patternfly-3.21.0.1.tar.gz
BuildArch: noarch
@@ -50,6 +50,13 @@ You can find more info about the xstatic packaging way in the package `XStatic`.
%install
%py3_install
+
+mkdir -p %{buildroot}%{_jsdir}/patternfly
+mv %{buildroot}%{python3_sitelib}/xstatic/pkg/patternfly/data/* %{buildroot}%{_jsdir}/patternfly
+rmdir %{buildroot}%{python3_sitelib}/xstatic/pkg/patternfly/data/
+# fix execute flags for js
+chmod 644 %{buildroot}%{_jsdir}/patternfly/js/*.js
+
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
@@ -57,20 +64,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -78,10 +85,11 @@ mv %{buildroot}/doclist.lst .
%files -n python3-XStatic-Patternfly -f filelist.lst
%dir %{python3_sitelib}/*
+%{_jsdir}/patternfly
%files help -f doclist.lst
%{_docdir}/*
%changelog
-* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 3.21.0.1-1
+* Thu May 25 2023 Python_Bot <Python_Bot@openeuler.org> - 3.21.0.1-1
- Package Spec generated