summaryrefslogtreecommitdiff
path: root/python-html5-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-html5-parser.spec')
-rw-r--r--python-html5-parser.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-html5-parser.spec b/python-html5-parser.spec
new file mode 100644
index 0000000..d4d3e71
--- /dev/null
+++ b/python-html5-parser.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-html5-parser
+Version: 0.4.11
+Release: 1
+Summary: Fast C based HTML 5 parsing for python
+License: Apache 2.0
+URL: https://html5-parser.readthedocs.io
+Source0: https://files.pythonhosted.org/packages/20/2d/f2f3d91d73b715e24943896a338be9591537e293522344b0acfd1ee75d92/html5-parser-0.4.11.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-html5-parser
+Summary: Fast C based HTML 5 parsing for python
+Provides: python-html5-parser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-html5-parser
+
+
+%package help
+Summary: Development documents and examples for html5-parser
+Provides: python3-html5-parser-doc
+%description help
+
+
+%prep
+%autosetup -n html5-parser-0.4.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-html5-parser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 27 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.11-1
+- Package Spec generated