From 81e665b9a8ffcf62652c83c460a6277c68dc2b73 Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 14 Feb 2025 06:57:03 +0000
Subject: automatic import of python-ipdb

---
 python-ipdb.spec | 89 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 89 insertions(+)
 create mode 100644 python-ipdb.spec

(limited to 'python-ipdb.spec')

diff --git a/python-ipdb.spec b/python-ipdb.spec
new file mode 100644
index 0000000..37849e2
--- /dev/null
+++ b/python-ipdb.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name:		python-ipdb
+Version:	0.13.13
+Release:	1
+Summary:	IPython-enabled pdb
+License:	BSD
+URL:		https://github.com/gotcha/ipdb
+Source0:	https://mirrors.aliyun.com/pypi/web/packages/3d/1b/7e07e7b752017f7693a0f4d41c13e5ca29ce8cbcfdcc1fd6c4ad8c0a27a0/ipdb-0.13.13.tar.gz
+BuildArch:	noarch
+
+Requires:	(python3-ipython<6.0.0 with python3-ipython>=5.1.0)
+Requires:	(python3-toml>=0.10.2)
+Requires:	(python3-decorator<5.0.0)
+Requires:	(python3-pathlib)
+Requires:	(python3-ipython<7.0.0 with python3-ipython>=6.0.0)
+Requires:	(python3-toml>=0.10.2)
+Requires:	(python3-decorator<5.0.0)
+Requires:	(python3-ipython<7.10.0 with python3-ipython>=7.0.0)
+Requires:	(python3-toml>=0.10.2)
+Requires:	(python3-decorator)
+Requires:	(python3-ipython<7.17.0 with python3-ipython>=7.16.3)
+Requires:	(python3-tomli)
+Requires:	(python3-decorator)
+Requires:	(python3-ipython>=7.31.1)
+Requires:	(python3-tomli)
+Requires:	(python3-decorator)
+Requires:	(python3-ipython>=7.31.1)
+Requires:	(python3-decorator)
+
+%description
+
+
+%package -n python3-ipdb
+Summary:	IPython-enabled pdb
+Provides:	python-ipdb
+BuildRequires:	python3-devel
+BuildRequires:	python3-setuptools
+BuildRequires:	python3-pip
+BuildRequires:	python3-wheel
+%description -n python3-ipdb
+
+
+%package help
+Summary:	Development documents and examples for ipdb
+Provides:	python3-ipdb-doc
+%description help
+
+
+%prep
+%autosetup -n ipdb-0.13.13
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch filelist.lst
+if [ -d usr/lib64 ]; then
+	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ipdb -f filelist.lst
+%{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 14 2025 Python_Bot <Python_Bot@openeuler.org> - 0.13.13-1
+- Package Spec generated
-- 
cgit v1.2.3