From a1b5cf905192f7ee7049894db70e8cbe1e350d2b Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Mon, 17 Feb 2025 08:57:11 +0000
Subject: automatic import of python-pygal

---
 python-pygal.spec | 99 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 99 insertions(+)
 create mode 100644 python-pygal.spec

(limited to 'python-pygal.spec')

diff --git a/python-pygal.spec b/python-pygal.spec
new file mode 100644
index 0000000..b98f6f5
--- /dev/null
+++ b/python-pygal.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name:		python-pygal
+Version:	3.0.1
+Release:	1
+Summary:	A Python svg graph plotting library
+License:	LGPL-3.0+
+URL:		https://www.pygal.org/
+Source0:	https://files.pythonhosted.org/packages/a8/db/021ea4fc623cbef831333bfb896374d2931be26c899d18c075579e955886/pygal-3.0.1.tar.gz
+BuildArch:	noarch
+
+Requires:	python3-sphinx
+Requires:	python3-sphinx-rtd-theme
+Requires:	python3-pygal-sphinx-directives
+Requires:	python3-lxml
+Requires:	python3-cairosvg
+Requires:	python3-pyquery
+Requires:	python3-flask
+Requires:	python3-cairosvg
+Requires:	python3-lxml
+Requires:	python3-pygal-maps-world
+Requires:	python3-pygal-maps-fr
+Requires:	python3-pygal-maps-ch
+Requires:	python3-coveralls
+Requires:	python3-pytest-runner
+Requires:	python3-pytest-cov
+Requires:	python3-pytest-flake8
+Requires:	python3-pytest-isort
+Requires:	python3-pytest
+
+%description
+A Python svg graph plotting library.
+
+
+%package -n python3-pygal
+Summary:	A Python svg graph plotting library
+Provides:	python-pygal
+BuildRequires:	python3-devel
+BuildRequires:	python3-setuptools
+BuildRequires:	python3-pip
+BuildRequires:	python3-wheel
+BuildRequires:	python3-pbr
+BuildRequires:	python3-pytest-runner
+%description -n python3-pygal
+
+
+%package help
+Summary:	Development documents and examples for pygal
+Provides:	python3-pygal-doc
+%description help
+
+
+%prep
+%autosetup -n pygal-3.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pygal -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Sep 14 2024 songliyang <songliyang@kylinos.cn> - 3.0.1-1
+- upgrade to v3.0.1
+- Use importlib instead of deprecated pkg_resources
+- Add python_requires to setup.py, to prevent installing on unsupported Python versions
+
+* Wed Jul 13 2022 cuiyudong <cuiyudong@kylinos.cn> - 3.0.0-1
+- Package init
-- 
cgit v1.2.3