%global _empty_manifest_terminate_build 0
Name:		python-0-core-client
Version:	1.1.0a8
Release:	1
Summary:	Zero-OS 0-core client
License:	Apache 2.0
URL:		https://github.com/zero-os/0-core
Source0:	https://mirrors.aliyun.com/pypi/web/packages/cd/1c/52c3a1c88b2a2821ea7d2afc3c7883a8d73880dd4de4199b8d5e7d9773bd/0-core-client-1.1.0a8.tar.gz
BuildArch:	noarch

Requires:	(python3-redis>=2.10.5)

%description
# Zero-OS Python Client
## Install

```bash
pip3 install 0-core-client
```

## How to use

```python
from zeroos.core0.client import Client

cl = Client(host='<0-core-host-address>', password='<JWT>')

#validate that core0 is reachable
print(cl.ping())

#then u can do stuff like
print(
    cl.system('ps -eF').get()
)

print(
    cl.system('ip a').get()
)

#client exposes more tools for disk, bridges, and container mgmt
print(
    cl.disk.list()
)
```




%package -n python3-0-core-client
Summary:	Zero-OS 0-core client
Provides:	python-0-core-client
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-wheel
%description -n python3-0-core-client
# Zero-OS Python Client
## Install

```bash
pip3 install 0-core-client
```

## How to use

```python
from zeroos.core0.client import Client

cl = Client(host='<0-core-host-address>', password='<JWT>')

#validate that core0 is reachable
print(cl.ping())

#then u can do stuff like
print(
    cl.system('ps -eF').get()
)

print(
    cl.system('ip a').get()
)

#client exposes more tools for disk, bridges, and container mgmt
print(
    cl.disk.list()
)
```




%package help
Summary:	Development documents and examples for 0-core-client
Provides:	python3-0-core-client-doc
%description help
# Zero-OS Python Client
## Install

```bash
pip3 install 0-core-client
```

## How to use

```python
from zeroos.core0.client import Client

cl = Client(host='<0-core-host-address>', password='<JWT>')

#validate that core0 is reachable
print(cl.ping())

#then u can do stuff like
print(
    cl.system('ps -eF').get()
)

print(
    cl.system('ip a').get()
)

#client exposes more tools for disk, bridges, and container mgmt
print(
    cl.disk.list()
)
```




%prep
%autosetup -n 0-core-client-1.1.0a8

%build
%pyproject_build

%install
%pyproject_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
touch filelist.lst
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-0-core-client -f filelist.lst
%{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Dec 17 2024 Python_Bot <Python_Bot@openeuler.org> - 1.1.0a8-1
- Package Spec generated