%global _empty_manifest_terminate_build 0
Name:		python-0x-middlewares
Version:	1.0.0
Release:	1
Summary:	Web3 middlewares for 0x applications
License:	Apache 2.0
URL:		https://github.com/0xproject/0x-monorepo/tree/development/python-packages/middlewares
Source0:	https://mirrors.aliyun.com/pypi/web/packages/09/b5/bf74af2c51bfa42ba8d822b30c8bd2da07a926cb7f14daf8adfdd95950f7/0x-middlewares-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-eth-account
Requires:	python3-eth-keys
Requires:	python3-hexbytes
Requires:	python3-mypy-extensions
Requires:	python3-0x-contract-addresses
Requires:	python3-0x-contract-wrappers
Requires:	python3-0x-order-utils
Requires:	python3-web3
Requires:	python3-bandit
Requires:	python3-black
Requires:	python3-coverage
Requires:	python3-coveralls
Requires:	python3-eth-utils
Requires:	python3-mypy
Requires:	python3-mypy-extensions
Requires:	python3-pycodestyle
Requires:	python3-pydocstyle
Requires:	python3-pylint
Requires:	python3-pytest
Requires:	python3-sphinx
Requires:	python3-sphinx-autodoc-typehints
Requires:	python3-tox
Requires:	python3-twine

%description
## 0x-middlewares

Web3 middlewares for 0x applications.

Read the [documentation](http://0x-middlewares-py.s3-website-us-east-1.amazonaws.com/)

## Installing

```bash
pip install 0x-middlewares
```

## Contributing

We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.

Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.

### Install Code and Dependencies

Ensure that you have installed Python >=3.6 and Docker. Then:

```bash
pip install -e .[dev]
```

### Test

Tests depend on running a local ethereum JSON-RPC server. For convenience, a docker container is provided that has ganache-cli.
A shortcut is provided to run that docker container: `./setup.py ganache`. With that running, the tests can be run with `./setup.py test`.

### Clean

`./setup.py clean --all`

### Lint

`./setup.py lint`

### Build Documentation

`./setup.py build_sphinx`

### More

See `./setup.py --help-commands` for more info.




%package -n python3-0x-middlewares
Summary:	Web3 middlewares for 0x applications
Provides:	python-0x-middlewares
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-0x-middlewares
## 0x-middlewares

Web3 middlewares for 0x applications.

Read the [documentation](http://0x-middlewares-py.s3-website-us-east-1.amazonaws.com/)

## Installing

```bash
pip install 0x-middlewares
```

## Contributing

We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.

Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.

### Install Code and Dependencies

Ensure that you have installed Python >=3.6 and Docker. Then:

```bash
pip install -e .[dev]
```

### Test

Tests depend on running a local ethereum JSON-RPC server. For convenience, a docker container is provided that has ganache-cli.
A shortcut is provided to run that docker container: `./setup.py ganache`. With that running, the tests can be run with `./setup.py test`.

### Clean

`./setup.py clean --all`

### Lint

`./setup.py lint`

### Build Documentation

`./setup.py build_sphinx`

### More

See `./setup.py --help-commands` for more info.




%package help
Summary:	Development documents and examples for 0x-middlewares
Provides:	python3-0x-middlewares-doc
%description help
## 0x-middlewares

Web3 middlewares for 0x applications.

Read the [documentation](http://0x-middlewares-py.s3-website-us-east-1.amazonaws.com/)

## Installing

```bash
pip install 0x-middlewares
```

## Contributing

We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.

Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.

### Install Code and Dependencies

Ensure that you have installed Python >=3.6 and Docker. Then:

```bash
pip install -e .[dev]
```

### Test

Tests depend on running a local ethereum JSON-RPC server. For convenience, a docker container is provided that has ganache-cli.
A shortcut is provided to run that docker container: `./setup.py ganache`. With that running, the tests can be run with `./setup.py test`.

### Clean

`./setup.py clean --all`

### Lint

`./setup.py lint`

### Build Documentation

`./setup.py build_sphinx`

### More

See `./setup.py --help-commands` for more info.




%prep
%autosetup -n 0x-middlewares-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-0x-middlewares -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated