From ff2dd68eac9af56cc1f132601add1fb7c7d2400d Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 5 May 2023 12:53:40 +0000
Subject: automatic import of python-1337x

---
 python-1337x.spec | 180 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 180 insertions(+)
 create mode 100644 python-1337x.spec

(limited to 'python-1337x.spec')

diff --git a/python-1337x.spec b/python-1337x.spec
new file mode 100644
index 0000000..54c864d
--- /dev/null
+++ b/python-1337x.spec
@@ -0,0 +1,180 @@
+%global _empty_manifest_terminate_build 0
+Name:		python-1337x
+Version:	1.2.4
+Release:	1
+Summary:	Unofficial API of 1337x.to
+License:	MIT License
+URL:		https://github.com/hemantapkh/1337x
+Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/88/40/8c93369ca75c91a428dce783f903abafab28b11f8bbc2cdf8bef2ceeca39/1337x-1.2.4.tar.gz
+BuildArch:	noarch
+
+Requires:	python3-requests
+Requires:	python3-bs4
+Requires:	python3-requests-cache
+
+%description
+torrents.search(query)  | Search for torrents | self,<br>query: `Keyword to search for`,<br>page (Defaults to 1): `Page to view`,<br>category (optional): [category](#available-categories),<br>sortBy (optional): [Sort by](#available-sorting-methods),<br>Order (optional): [order](#available-sorting-order)
+torrents.trending()     | Get trending torrents | self,<br>category (optional): [category](#available-categories),<br>week (Defaults to False): `True for weekely, False for daily`
+torrents.top()          | Get top torrents      | self,<br>category (optional): [category](#available-categories)
+torrents.popular(category)          | Get popular torrents      | self,<br>category: [category](#available-categories),<br>week (Defaults to False): `True for weekely, False for daily`
+torrents.browse(category)          | Browse browse of certain category      | self,<br>category: [category](#available-categories),<br>page (Defaults to 1): `Page to view`
+torrents&#46;info(link or torrentId)          | Get information of a torrent      | self,<br>link: `Link of a torrent` or<br>torrentId: `ID of a torrent`
+### Available categories
+ - `'movies'`
+ - `'tv'`
+ - `'games'`
+ - `'music'`
+ - `'apps'`
+ - `'anime'`
+ - `'documentaries'`
+ - `'xxx'`
+ - `'others'`
+### Available sorting methods
+- `'time'`
+- `'size'`
+- `'seeders'`
+- `'leechers'`
+### Available sorting order
+- `'desc'` (for descending order)
+- `'asc'` (for ascending order)
+## Contributing
+Any contributions you make are **greatly appreciated**.
+1. Fork the Project
+2. Create your Feature Branch (`git checkout -b feature/AmazingFeature`)
+3. Commit your Changes (`git commit -m 'Add some AmazingFeature'`)
+4. Push to the Branch (`git push origin feature/AmazingFeature`)
+5. Open a Pull Request
+*Thanks to every [contributors](https://github.com/hemantapkh/1337x/graphs/contributors) who have contributed in this project.*
+## Projects using this API
+* [Torrent Hunt](https://github.com/hemantapkh/torrenthunt) - Telegram bot to search torrents.
+Want to list your project here? Just make a pull request.
+## License
+
+%package -n python3-1337x
+Summary:	Unofficial API of 1337x.to
+Provides:	python-1337x
+BuildRequires:	python3-devel
+BuildRequires:	python3-setuptools
+BuildRequires:	python3-pip
+%description -n python3-1337x
+torrents.search(query)  | Search for torrents | self,<br>query: `Keyword to search for`,<br>page (Defaults to 1): `Page to view`,<br>category (optional): [category](#available-categories),<br>sortBy (optional): [Sort by](#available-sorting-methods),<br>Order (optional): [order](#available-sorting-order)
+torrents.trending()     | Get trending torrents | self,<br>category (optional): [category](#available-categories),<br>week (Defaults to False): `True for weekely, False for daily`
+torrents.top()          | Get top torrents      | self,<br>category (optional): [category](#available-categories)
+torrents.popular(category)          | Get popular torrents      | self,<br>category: [category](#available-categories),<br>week (Defaults to False): `True for weekely, False for daily`
+torrents.browse(category)          | Browse browse of certain category      | self,<br>category: [category](#available-categories),<br>page (Defaults to 1): `Page to view`
+torrents&#46;info(link or torrentId)          | Get information of a torrent      | self,<br>link: `Link of a torrent` or<br>torrentId: `ID of a torrent`
+### Available categories
+ - `'movies'`
+ - `'tv'`
+ - `'games'`
+ - `'music'`
+ - `'apps'`
+ - `'anime'`
+ - `'documentaries'`
+ - `'xxx'`
+ - `'others'`
+### Available sorting methods
+- `'time'`
+- `'size'`
+- `'seeders'`
+- `'leechers'`
+### Available sorting order
+- `'desc'` (for descending order)
+- `'asc'` (for ascending order)
+## Contributing
+Any contributions you make are **greatly appreciated**.
+1. Fork the Project
+2. Create your Feature Branch (`git checkout -b feature/AmazingFeature`)
+3. Commit your Changes (`git commit -m 'Add some AmazingFeature'`)
+4. Push to the Branch (`git push origin feature/AmazingFeature`)
+5. Open a Pull Request
+*Thanks to every [contributors](https://github.com/hemantapkh/1337x/graphs/contributors) who have contributed in this project.*
+## Projects using this API
+* [Torrent Hunt](https://github.com/hemantapkh/torrenthunt) - Telegram bot to search torrents.
+Want to list your project here? Just make a pull request.
+## License
+
+%package help
+Summary:	Development documents and examples for 1337x
+Provides:	python3-1337x-doc
+%description help
+torrents.search(query)  | Search for torrents | self,<br>query: `Keyword to search for`,<br>page (Defaults to 1): `Page to view`,<br>category (optional): [category](#available-categories),<br>sortBy (optional): [Sort by](#available-sorting-methods),<br>Order (optional): [order](#available-sorting-order)
+torrents.trending()     | Get trending torrents | self,<br>category (optional): [category](#available-categories),<br>week (Defaults to False): `True for weekely, False for daily`
+torrents.top()          | Get top torrents      | self,<br>category (optional): [category](#available-categories)
+torrents.popular(category)          | Get popular torrents      | self,<br>category: [category](#available-categories),<br>week (Defaults to False): `True for weekely, False for daily`
+torrents.browse(category)          | Browse browse of certain category      | self,<br>category: [category](#available-categories),<br>page (Defaults to 1): `Page to view`
+torrents&#46;info(link or torrentId)          | Get information of a torrent      | self,<br>link: `Link of a torrent` or<br>torrentId: `ID of a torrent`
+### Available categories
+ - `'movies'`
+ - `'tv'`
+ - `'games'`
+ - `'music'`
+ - `'apps'`
+ - `'anime'`
+ - `'documentaries'`
+ - `'xxx'`
+ - `'others'`
+### Available sorting methods
+- `'time'`
+- `'size'`
+- `'seeders'`
+- `'leechers'`
+### Available sorting order
+- `'desc'` (for descending order)
+- `'asc'` (for ascending order)
+## Contributing
+Any contributions you make are **greatly appreciated**.
+1. Fork the Project
+2. Create your Feature Branch (`git checkout -b feature/AmazingFeature`)
+3. Commit your Changes (`git commit -m 'Add some AmazingFeature'`)
+4. Push to the Branch (`git push origin feature/AmazingFeature`)
+5. Open a Pull Request
+*Thanks to every [contributors](https://github.com/hemantapkh/1337x/graphs/contributors) who have contributed in this project.*
+## Projects using this API
+* [Torrent Hunt](https://github.com/hemantapkh/torrenthunt) - Telegram bot to search torrents.
+Want to list your project here? Just make a pull request.
+## License
+
+%prep
+%autosetup -n 1337x-1.2.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-1337x -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.4-1
+- Package Spec generated
-- 
cgit v1.2.3