summaryrefslogtreecommitdiff
path: root/python-1pass.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-1pass.spec')
-rw-r--r--python-1pass.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-1pass.spec b/python-1pass.spec
new file mode 100644
index 0000000..b1de8f1
--- /dev/null
+++ b/python-1pass.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-1pass
+Version: 0.2.1
+Release: 1
+Summary: A Python library and command line interface for 1Password
+License: MIT
+URL: http://github.com/georgebrock/1pass
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/94/52/256afae40ca6b8083c13165a5068d848844709c928302efaacaeb9e361c7/1pass-0.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-1pass
+Summary: A Python library and command line interface for 1Password
+Provides: python-1pass
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-1pass
+
+
+%package help
+Summary: Development documents and examples for 1pass
+Provides: python3-1pass-doc
+%description help
+
+
+%prep
+%autosetup -n 1pass-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-1pass -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated