summaryrefslogtreecommitdiff
path: root/python-3debt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-3debt.spec')
-rw-r--r--python-3debt.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-3debt.spec b/python-3debt.spec
new file mode 100644
index 0000000..f0ffb35
--- /dev/null
+++ b/python-3debt.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-3debt
+Version: 0.0.6
+Release: 1
+Summary: Python 3 dependency checker
+License: MIT License
+URL: https://github.com/akoskaaa/3debt
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/99/e2/b782f101d0644204e144a4e6b16ab163e19ff64768c07fdbd2ddb8a18775/3debt-0.0.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-argparse
+Requires: python3-requests
+
+%description
+# 3debt
+Try to figure out what dependencies you're missing to start upgrading your project to Python 3
+
+## Installation
+pip install -g 3debt
+
+## Usage
+3debt requirements.txt
+
+
+
+
+%package -n python3-3debt
+Summary: Python 3 dependency checker
+Provides: python-3debt
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-3debt
+# 3debt
+Try to figure out what dependencies you're missing to start upgrading your project to Python 3
+
+## Installation
+pip install -g 3debt
+
+## Usage
+3debt requirements.txt
+
+
+
+
+%package help
+Summary: Development documents and examples for 3debt
+Provides: python3-3debt-doc
+%description help
+# 3debt
+Try to figure out what dependencies you're missing to start upgrading your project to Python 3
+
+## Installation
+pip install -g 3debt
+
+## Usage
+3debt requirements.txt
+
+
+
+
+%prep
+%autosetup -n 3debt-0.0.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-3debt -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.6-1
+- Package Spec generated