summaryrefslogtreecommitdiff
path: root/python-3dof-hexapod-ik-generator.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:22:12 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:22:12 +0000
commit3dce82b7dddbd6c51f3f4c6feeab52aafae73d11 (patch)
treead5bca751abf184a78b8f25728e66a8a5bf7f258 /python-3dof-hexapod-ik-generator.spec
parent61a875cd7b0ad395dc1b1c52c47eebef339d4112 (diff)
automatic import of python-3dof-hexapod-ik-generator
Diffstat (limited to 'python-3dof-hexapod-ik-generator.spec')
-rw-r--r--python-3dof-hexapod-ik-generator.spec111
1 files changed, 111 insertions, 0 deletions
diff --git a/python-3dof-hexapod-ik-generator.spec b/python-3dof-hexapod-ik-generator.spec
new file mode 100644
index 0000000..1fc7352
--- /dev/null
+++ b/python-3dof-hexapod-ik-generator.spec
@@ -0,0 +1,111 @@
+%global _empty_manifest_terminate_build 0
+Name: python-3dof-hexapod-ik-generator
+Version: 1.0.0
+Release: 1
+Summary: This is a module which calculates IK servo angles for leaning and shifting a 3dof hexapod's body.
+License: MIT
+URL: https://github.com/macaquedev
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9b/2b/2a7b32dad61d8bd7dd38c699b9d66ea39b29b636b707ff87cd651b5ed980/3dof-hexapod-ik-generator-1.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+This is a simple Python package for hexapod IK calculations.
+
+Commands:
+
+To be imported as ikengine
+
+class IKEngine # initialises the class object. Takes 4 arguments in mm - coxaLength, femurLength, tibiaLength and bodySideLength. Optionally can take a 5th argument that can either be a list or a tuple. Please pass the servos that need to be reversed into this tuple/list. They will be reversed (angle = 180 - angle) for the whole runtime of your program that utilises this library.
+
+shift_lean(posX, posY, posZ, rotX, rotY, rotZ) # returns an array of 18 servo angles that are calculated using IK from the given variables that correspond to the translation and tilt of the body of the hexapod. The order goes from tibia to coxa, from left to right and then from front to back
+
+Any questions or suggestions? Please feel free to contact me at macaquedev@gmail.com
+
+
+
+
+%package -n python3-3dof-hexapod-ik-generator
+Summary: This is a module which calculates IK servo angles for leaning and shifting a 3dof hexapod's body.
+Provides: python-3dof-hexapod-ik-generator
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-3dof-hexapod-ik-generator
+This is a simple Python package for hexapod IK calculations.
+
+Commands:
+
+To be imported as ikengine
+
+class IKEngine # initialises the class object. Takes 4 arguments in mm - coxaLength, femurLength, tibiaLength and bodySideLength. Optionally can take a 5th argument that can either be a list or a tuple. Please pass the servos that need to be reversed into this tuple/list. They will be reversed (angle = 180 - angle) for the whole runtime of your program that utilises this library.
+
+shift_lean(posX, posY, posZ, rotX, rotY, rotZ) # returns an array of 18 servo angles that are calculated using IK from the given variables that correspond to the translation and tilt of the body of the hexapod. The order goes from tibia to coxa, from left to right and then from front to back
+
+Any questions or suggestions? Please feel free to contact me at macaquedev@gmail.com
+
+
+
+
+%package help
+Summary: Development documents and examples for 3dof-hexapod-ik-generator
+Provides: python3-3dof-hexapod-ik-generator-doc
+%description help
+This is a simple Python package for hexapod IK calculations.
+
+Commands:
+
+To be imported as ikengine
+
+class IKEngine # initialises the class object. Takes 4 arguments in mm - coxaLength, femurLength, tibiaLength and bodySideLength. Optionally can take a 5th argument that can either be a list or a tuple. Please pass the servos that need to be reversed into this tuple/list. They will be reversed (angle = 180 - angle) for the whole runtime of your program that utilises this library.
+
+shift_lean(posX, posY, posZ, rotX, rotY, rotZ) # returns an array of 18 servo angles that are calculated using IK from the given variables that correspond to the translation and tilt of the body of the hexapod. The order goes from tibia to coxa, from left to right and then from front to back
+
+Any questions or suggestions? Please feel free to contact me at macaquedev@gmail.com
+
+
+
+
+%prep
+%autosetup -n 3dof-hexapod-ik-generator-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-3dof-hexapod-ik-generator -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated