summaryrefslogtreecommitdiff
path: root/python-admmftire.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-admmftire.spec')
-rw-r--r--python-admmftire.spec135
1 files changed, 135 insertions, 0 deletions
diff --git a/python-admmftire.spec b/python-admmftire.spec
new file mode 100644
index 0000000..dd2b1d3
--- /dev/null
+++ b/python-admmftire.spec
@@ -0,0 +1,135 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ADMMFTIRE
+Version: 0.0.3
+Release: 1
+Summary: An ADMMFTIRE package
+License: MIT License
+URL: https://github.com/SDR-VariableSelection/ADMMFTIRE
+Source0: https://mirrors.aliyun.com/pypi/web/packages/78/38/86bbb398e612d57f158c09d0ff024dcdca8819968c36e5c43cc8ba24f083/ADMMFTIRE-0.0.3.tar.gz
+BuildArch: noarch
+
+
+%description
+# Description
+
+This is a ADMM-FTIRE package for the submitted paper "An Iterative ADMM Algorithm in Ultrahigh Dimensional Sufficient Dimension Reduction".
+
+# Installation
+
+pip install ADMMFTIRE==0.0.3
+
+# Example
+
+import FTIRE
+
+from FTIRE import *
+
+X = genxy.generateX(100, 50, 0)
+
+y, d, q, b = genxy.generateY(X, 1)
+
+B = ftire.CV(X, y, d, 30, "ft")
+
+
+
+
+%package -n python3-ADMMFTIRE
+Summary: An ADMMFTIRE package
+Provides: python-ADMMFTIRE
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ADMMFTIRE
+# Description
+
+This is a ADMM-FTIRE package for the submitted paper "An Iterative ADMM Algorithm in Ultrahigh Dimensional Sufficient Dimension Reduction".
+
+# Installation
+
+pip install ADMMFTIRE==0.0.3
+
+# Example
+
+import FTIRE
+
+from FTIRE import *
+
+X = genxy.generateX(100, 50, 0)
+
+y, d, q, b = genxy.generateY(X, 1)
+
+B = ftire.CV(X, y, d, 30, "ft")
+
+
+
+
+%package help
+Summary: Development documents and examples for ADMMFTIRE
+Provides: python3-ADMMFTIRE-doc
+%description help
+# Description
+
+This is a ADMM-FTIRE package for the submitted paper "An Iterative ADMM Algorithm in Ultrahigh Dimensional Sufficient Dimension Reduction".
+
+# Installation
+
+pip install ADMMFTIRE==0.0.3
+
+# Example
+
+import FTIRE
+
+from FTIRE import *
+
+X = genxy.generateX(100, 50, 0)
+
+y, d, q, b = genxy.generateY(X, 1)
+
+B = ftire.CV(X, y, d, 30, "ft")
+
+
+
+
+%prep
+%autosetup -n ADMMFTIRE-0.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ADMMFTIRE -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3-1
+- Package Spec generated