summaryrefslogtreecommitdiff
path: root/python-alp4lib.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 08:21:29 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 08:21:29 +0000
commit17e27ce1eda4a354f4c934902174f72ea9d63d53 (patch)
treeec9448fad52286b5b640307efc57c975990c16e5 /python-alp4lib.spec
parent791ba95422120e0e15f7af38418e03d5756c7a37 (diff)
automatic import of python-ALP4libopeneuler20.03
Diffstat (limited to 'python-alp4lib.spec')
-rw-r--r--python-alp4lib.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-alp4lib.spec b/python-alp4lib.spec
new file mode 100644
index 0000000..e357d50
--- /dev/null
+++ b/python-alp4lib.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ALP4lib
+Version: 1.0.1
+Release: 1
+Summary: A module to control Vialux DMDs based on ALP4.X API.It uses the .ddl files provided by Vialux.
+License: MIT
+URL: https://github.com/wavefronthsaping/ALP4lib
+Source0: https://mirrors.aliyun.com/pypi/web/packages/76/86/045e85dfe8c9d3fc3bc00e3444e3eb7173bd95af2f6b562825f8d6d7c8bb/ALP4lib-1.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-matplotlib
+Requires: python3-scipy
+Requires: python3-numba
+Requires: python3-joblib
+
+%description
+Please read the documentation on Github and official Vialux documentation.
+
+
+
+%package -n python3-ALP4lib
+Summary: A module to control Vialux DMDs based on ALP4.X API.It uses the .ddl files provided by Vialux.
+Provides: python-ALP4lib
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ALP4lib
+Please read the documentation on Github and official Vialux documentation.
+
+
+
+%package help
+Summary: Development documents and examples for ALP4lib
+Provides: python3-ALP4lib-doc
+%description help
+Please read the documentation on Github and official Vialux documentation.
+
+
+
+%prep
+%autosetup -n ALP4lib-1.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ALP4lib -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
+- Package Spec generated