summaryrefslogtreecommitdiff
path: root/python-APLpy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-APLpy.spec')
-rw-r--r--python-APLpy.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-APLpy.spec b/python-APLpy.spec
new file mode 100644
index 0000000..c2dc781
--- /dev/null
+++ b/python-APLpy.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aplpy
+Version: 2.1.0
+Release: 1
+Summary: The Astronomical Plotting Library in Python
+License: MIT
+URL: http://aplpy.github.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/bf/949e933714334f7a283d602079fa1da84124752eff7f4869b10e8cc1fcff/aplpy-2.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-astropy
+Requires: python3-matplotlib
+Requires: python3-reproject
+Requires: python3-pyregion
+Requires: python3-pillow
+Requires: python3-pyavm
+Requires: python3-scikit-image
+Requires: python3-shapely
+Requires: python3-sphinx-astropy
+Requires: python3-pytest-astropy
+Requires: python3-pytest-mpl
+
+%description
+APLpy (the Astronomical Plotting Library in Python) is a Python module
+aimed at producing publication-quality plots of astronomical imaging
+data in FITS format.
+PyPI: https://pypi.python.org/pypi/APLpy
+Website: http://aplpy.github.io
+Documentation: http://aplpy.readthedocs.io
+APLpy is released under an MIT open-source license.
+
+%package -n python3-aplpy
+Summary: The Astronomical Plotting Library in Python
+Provides: python-aplpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aplpy
+APLpy (the Astronomical Plotting Library in Python) is a Python module
+aimed at producing publication-quality plots of astronomical imaging
+data in FITS format.
+PyPI: https://pypi.python.org/pypi/APLpy
+Website: http://aplpy.github.io
+Documentation: http://aplpy.readthedocs.io
+APLpy is released under an MIT open-source license.
+
+%package help
+Summary: Development documents and examples for aplpy
+Provides: python3-aplpy-doc
+%description help
+APLpy (the Astronomical Plotting Library in Python) is a Python module
+aimed at producing publication-quality plots of astronomical imaging
+data in FITS format.
+PyPI: https://pypi.python.org/pypi/APLpy
+Website: http://aplpy.github.io
+Documentation: http://aplpy.readthedocs.io
+APLpy is released under an MIT open-source license.
+
+%prep
+%autosetup -n aplpy-2.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aplpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
+- Package Spec generated