summaryrefslogtreecommitdiff
path: root/python-assessor.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-assessor.spec')
-rw-r--r--python-assessor.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-assessor.spec b/python-assessor.spec
new file mode 100644
index 0000000..10088a8
--- /dev/null
+++ b/python-assessor.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Assessor
+Version: 0.2.13
+Release: 1
+Summary: Django Assessment App
+License: UNKNOWN
+URL: http://www.justinzane.com/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/91/91/8aec9368f1be8f51dad216123b8b928b12e05795bd9273065faba0d76ded/Assessor-0.2.13.tar.bz2
+BuildArch: noarch
+
+
+%description
+Simple Assessment (Quiz) App with Django, Tastypie and ExtJS
+LICENSE: AGPLv3
+NOTE: Currently setup to use questions from practice exams for the CA BBS MFT
+certification exams. These are copyrighted and not for public use.
+To use, you must create questions, choices and explanations manually.
+TODO:
+- Create UI for question/choice/explanation creation
+- Create UI for answer history
+- Create UI for user authentication and authorization
+- Create standalone install for Android
+- Optimize AJAX calls, including LoadMask indicator
+
+%package -n python3-Assessor
+Summary: Django Assessment App
+Provides: python-Assessor
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Assessor
+Simple Assessment (Quiz) App with Django, Tastypie and ExtJS
+LICENSE: AGPLv3
+NOTE: Currently setup to use questions from practice exams for the CA BBS MFT
+certification exams. These are copyrighted and not for public use.
+To use, you must create questions, choices and explanations manually.
+TODO:
+- Create UI for question/choice/explanation creation
+- Create UI for answer history
+- Create UI for user authentication and authorization
+- Create standalone install for Android
+- Optimize AJAX calls, including LoadMask indicator
+
+%package help
+Summary: Development documents and examples for Assessor
+Provides: python3-Assessor-doc
+%description help
+Simple Assessment (Quiz) App with Django, Tastypie and ExtJS
+LICENSE: AGPLv3
+NOTE: Currently setup to use questions from practice exams for the CA BBS MFT
+certification exams. These are copyrighted and not for public use.
+To use, you must create questions, choices and explanations manually.
+TODO:
+- Create UI for question/choice/explanation creation
+- Create UI for answer history
+- Create UI for user authentication and authorization
+- Create standalone install for Android
+- Optimize AJAX calls, including LoadMask indicator
+
+%prep
+%autosetup -n Assessor.tar-0.2.13
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Assessor -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.13-1
+- Package Spec generated