%global _empty_manifest_terminate_build 0
Name:		python-CodonGenie
Version:	1.7
Release:	1
Summary:	CodonGenie
License:	MIT License
URL:		https://github.com/neilswainston/CodonGenie
Source0:	https://mirrors.aliyun.com/pypi/web/packages/b9/d9/1e4a5bdd92723bc82a86db2b050f2b8f4386f7fb41a78dfb8f61971e596c/CodonGenie-1.7.tar.gz
BuildArch:	noarch


%description
#  To run with Docker:

1. Clone repository:

git clone https://github.com/synbiochem/CodonGenie.git

2. Navigate to CodonGenie directory:

cd CodonGenie

3. Run start_server script, with optional port (if port is not provided, a
   randomly assigned empty port will be provided):

bash start_server.sh 80



%package -n python3-CodonGenie
Summary:	CodonGenie
Provides:	python-CodonGenie
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-CodonGenie
#  To run with Docker:

1. Clone repository:

git clone https://github.com/synbiochem/CodonGenie.git

2. Navigate to CodonGenie directory:

cd CodonGenie

3. Run start_server script, with optional port (if port is not provided, a
   randomly assigned empty port will be provided):

bash start_server.sh 80



%package help
Summary:	Development documents and examples for CodonGenie
Provides:	python3-CodonGenie-doc
%description help
#  To run with Docker:

1. Clone repository:

git clone https://github.com/synbiochem/CodonGenie.git

2. Navigate to CodonGenie directory:

cd CodonGenie

3. Run start_server script, with optional port (if port is not provided, a
   randomly assigned empty port will be provided):

bash start_server.sh 80



%prep
%autosetup -n CodonGenie-1.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-CodonGenie -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7-1
- Package Spec generated