From fab06547f088677f9842b357333d72a0b661d61d Mon Sep 17 00:00:00 2001
From: CoprDistGit <copr-devel@lists.fedorahosted.org>
Date: Mon, 6 Mar 2023 12:49:10 +0000
Subject: automatic import of python-PyDrive

---
 python-PyDrive.spec | 78 +++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 78 insertions(+)
 create mode 100644 python-PyDrive.spec

(limited to 'python-PyDrive.spec')

diff --git a/python-PyDrive.spec b/python-PyDrive.spec
new file mode 100644
index 0000000..665d9a2
--- /dev/null
+++ b/python-PyDrive.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name:		python-PyDrive
+Version:	1.3.1
+Release:	1
+Summary:	Google Drive API made easy.
+License:	LICENSE
+URL:		https://github.com/googledrive/PyDrive
+Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/52/e0/0e64788e5dd58ce2d6934549676243dc69d982f198524be9b99e9c2a4fd5/PyDrive-1.3.1.tar.gz
+BuildArch:	noarch
+
+
+%description
+*PyDrive* is a wrapper library of
+`google-api-python-client <https://code.google.com/p/google-api-python-client/>`_
+that simplifies many common Google Drive API tasks.
+
+%package -n python3-PyDrive
+Summary:	Google Drive API made easy.
+Provides:	python-PyDrive
+BuildRequires:	python3-devel
+BuildRequires:	python3-setuptools
+BuildRequires:	python3-pip
+%description -n python3-PyDrive
+*PyDrive* is a wrapper library of
+`google-api-python-client <https://code.google.com/p/google-api-python-client/>`_
+that simplifies many common Google Drive API tasks.
+
+%package help
+Summary:	Development documents and examples for PyDrive
+Provides:	python3-PyDrive-doc
+%description help
+*PyDrive* is a wrapper library of
+`google-api-python-client <https://code.google.com/p/google-api-python-client/>`_
+that simplifies many common Google Drive API tasks.
+
+%prep
+%autosetup -n PyDrive-1.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyDrive -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.1-1
+- Package Spec generated
-- 
cgit v1.2.3