summaryrefslogtreecommitdiff
path: root/python-PyLink.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-PyLink.spec')
-rw-r--r--python-PyLink.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-PyLink.spec b/python-PyLink.spec
new file mode 100644
index 0000000..a765241
--- /dev/null
+++ b/python-PyLink.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyLink
+Version: 0.3.3
+Release: 1
+Summary: Universal communication interface using File-Like API
+License: BSD
+URL: https://github.com/SalemHarrache/PyLink
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0c/42/c4b5562a88fc7cd0b42564ee58eac5fb26ea576e92042d16ef0687831a6b/PyLink-0.3.3.tar.gz
+BuildArch: noarch
+
+
+%description
+Pylink offers a universal communication interface using File-Like API.
+For now, only the **TCP**, **UDP**, **Serial** and **GSM** interfaces are
+supported.
+The aim of this project is to allow any type of communication.
+It is best suited for projects that have various ways of communicating
+including IP remote or local serial communication.
+
+%package -n python3-PyLink
+Summary: Universal communication interface using File-Like API
+Provides: python-PyLink
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-PyLink
+Pylink offers a universal communication interface using File-Like API.
+For now, only the **TCP**, **UDP**, **Serial** and **GSM** interfaces are
+supported.
+The aim of this project is to allow any type of communication.
+It is best suited for projects that have various ways of communicating
+including IP remote or local serial communication.
+
+%package help
+Summary: Development documents and examples for PyLink
+Provides: python3-PyLink-doc
+%description help
+Pylink offers a universal communication interface using File-Like API.
+For now, only the **TCP**, **UDP**, **Serial** and **GSM** interfaces are
+supported.
+The aim of this project is to allow any type of communication.
+It is best suited for projects that have various ways of communicating
+including IP remote or local serial communication.
+
+%prep
+%autosetup -n PyLink-0.3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyLink -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.3-1
+- Package Spec generated