summaryrefslogtreecommitdiff
path: root/python-Pykka.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-Pykka.spec')
-rw-r--r--python-Pykka.spec142
1 files changed, 142 insertions, 0 deletions
diff --git a/python-Pykka.spec b/python-Pykka.spec
new file mode 100644
index 0000000..b9e2434
--- /dev/null
+++ b/python-Pykka.spec
@@ -0,0 +1,142 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pykka
+Version: 3.1.1
+Release: 1
+Summary: Pykka is a Python implementation of the actor model
+License: Apache-2.0
+URL: https://github.com/jodal/pykka
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/45/e9/ba139b5becd0e4bdf10a816af3fc17f788ac630159ca959d6da44d91a7be/pykka-3.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-importlib_metadata
+
+%description
+Pykka is a Python implementation of the
+[actor model](https://en.wikipedia.org/wiki/Actor_model).
+The actor model introduces some simple rules to control
+the sharing of state and cooperation between execution units,
+which makes it easier to build concurrent applications.
+For a quickstart guide and a complete API reference,
+see the [documentation](https://pykka.readthedocs.io/).
+## Installation
+Pykka requires Python 3.7 or newer.
+Pykka is available from [PyPI](https://pypi.org/project/pykka/):
+```
+python3 -m pip install pykka
+```
+## Project resources
+- [Documentation](https://pykka.readthedocs.io/)
+- [Source code](https://github.com/jodal/pykka)
+- [Releases](https://github.com/jodal/pykka/releases)
+- [Issue tracker](https://github.com/jodal/pykka/issues)
+- [Contributors](https://github.com/jodal/pykka/graphs/contributors)
+- [Users](https://github.com/jodal/pykka/wiki/Users)
+## License
+Pykka is copyright 2010-2022 Stein Magnus Jodal and contributors.
+Pykka is licensed under the
+[Apache License, Version 2.0](https://www.apache.org/licenses/LICENSE-2.0).
+
+%package -n python3-pykka
+Summary: Pykka is a Python implementation of the actor model
+Provides: python-pykka
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pykka
+Pykka is a Python implementation of the
+[actor model](https://en.wikipedia.org/wiki/Actor_model).
+The actor model introduces some simple rules to control
+the sharing of state and cooperation between execution units,
+which makes it easier to build concurrent applications.
+For a quickstart guide and a complete API reference,
+see the [documentation](https://pykka.readthedocs.io/).
+## Installation
+Pykka requires Python 3.7 or newer.
+Pykka is available from [PyPI](https://pypi.org/project/pykka/):
+```
+python3 -m pip install pykka
+```
+## Project resources
+- [Documentation](https://pykka.readthedocs.io/)
+- [Source code](https://github.com/jodal/pykka)
+- [Releases](https://github.com/jodal/pykka/releases)
+- [Issue tracker](https://github.com/jodal/pykka/issues)
+- [Contributors](https://github.com/jodal/pykka/graphs/contributors)
+- [Users](https://github.com/jodal/pykka/wiki/Users)
+## License
+Pykka is copyright 2010-2022 Stein Magnus Jodal and contributors.
+Pykka is licensed under the
+[Apache License, Version 2.0](https://www.apache.org/licenses/LICENSE-2.0).
+
+%package help
+Summary: Development documents and examples for pykka
+Provides: python3-pykka-doc
+%description help
+Pykka is a Python implementation of the
+[actor model](https://en.wikipedia.org/wiki/Actor_model).
+The actor model introduces some simple rules to control
+the sharing of state and cooperation between execution units,
+which makes it easier to build concurrent applications.
+For a quickstart guide and a complete API reference,
+see the [documentation](https://pykka.readthedocs.io/).
+## Installation
+Pykka requires Python 3.7 or newer.
+Pykka is available from [PyPI](https://pypi.org/project/pykka/):
+```
+python3 -m pip install pykka
+```
+## Project resources
+- [Documentation](https://pykka.readthedocs.io/)
+- [Source code](https://github.com/jodal/pykka)
+- [Releases](https://github.com/jodal/pykka/releases)
+- [Issue tracker](https://github.com/jodal/pykka/issues)
+- [Contributors](https://github.com/jodal/pykka/graphs/contributors)
+- [Users](https://github.com/jodal/pykka/wiki/Users)
+## License
+Pykka is copyright 2010-2022 Stein Magnus Jodal and contributors.
+Pykka is licensed under the
+[Apache License, Version 2.0](https://www.apache.org/licenses/LICENSE-2.0).
+
+%prep
+%autosetup -n pykka-3.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pykka -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.1-1
+- Package Spec generated