summaryrefslogtreecommitdiff
path: root/python-ROPGadget.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ROPGadget.spec')
-rw-r--r--python-ROPGadget.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-ROPGadget.spec b/python-ROPGadget.spec
new file mode 100644
index 0000000..067474b
--- /dev/null
+++ b/python-ROPGadget.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ROPGadget
+Version: 7.2
+Release: 1
+Summary: This tool lets you search your gadgets on your binaries to facilitate your ROP exploitation.
+License: BSD
+URL: https://github.com/JonathanSalwan/ROPgadget
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/80/cc/476fd64384b2e238b984e13be09a068f2ff61917e53267c3274a3574c309/ROPGadget-7.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-capstone
+
+%description
+ROPgadget supports ELF, PE and Mach-O format on x86, x64, ARM, ARM64, PowerPC, SPARC and MIPS architectures.
+http://www.shell-storm.org/project/ROPgadget/
+
+
+
+%package -n python3-ROPGadget
+Summary: This tool lets you search your gadgets on your binaries to facilitate your ROP exploitation.
+Provides: python-ROPGadget
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ROPGadget
+ROPgadget supports ELF, PE and Mach-O format on x86, x64, ARM, ARM64, PowerPC, SPARC and MIPS architectures.
+http://www.shell-storm.org/project/ROPgadget/
+
+
+
+%package help
+Summary: Development documents and examples for ROPGadget
+Provides: python3-ROPGadget-doc
+%description help
+ROPgadget supports ELF, PE and Mach-O format on x86, x64, ARM, ARM64, PowerPC, SPARC and MIPS architectures.
+http://www.shell-storm.org/project/ROPgadget/
+
+
+
+%prep
+%autosetup -n ROPGadget-7.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ROPGadget -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 7.2-1
+- Package Spec generated