summaryrefslogtreecommitdiff
path: root/python-aaargh.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-02-25 09:50:43 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-02-25 09:50:43 +0000
commit7ffb634468de00bdaa2a81abe90fe33464f07efd (patch)
tree1fecee788e233f6118009cc3b6449b0284c4961e /python-aaargh.spec
parent4c1de026b606a08840d2e40e036ba0914f2d53b3 (diff)
automatic import of python-aaargh
Diffstat (limited to 'python-aaargh.spec')
-rw-r--r--python-aaargh.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/python-aaargh.spec b/python-aaargh.spec
new file mode 100644
index 0000000..9b3d961
--- /dev/null
+++ b/python-aaargh.spec
@@ -0,0 +1,95 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aaargh
+Version: 0.7.1
+Release: 1
+Summary: An astonishingly awesome application argument helper
+License: BSD
+URL: https://github.com/wbolster/aaargh
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/96/84/357793da71eba670c850e572d772ea8c8b889247377fb24238bc1f95edf8/aaargh-0.7.1.tar.gz
+BuildArch: noarch
+
+
+%description
+The Python standard library contains the *optparse*, *getopt*, and *argparse*
+modules, and out in the wild you will find many alternative command line
+interface libraries stacked on top of these, such as *cliff*, *cement*,
+*opster*, *plac*, and many others. Some of these libraries separate the command
+line interface setup of your application from the actual code, some force yet
+another argument parsing API upon you, some force you to hide your code in
+non-obvious framework constructs, and some even add dependencies on other
+modules.
+This makes you scream *aaargh*. And, lo and behold, here it is!
+
+%package -n python3-aaargh
+Summary: An astonishingly awesome application argument helper
+Provides: python-aaargh
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-aaargh
+The Python standard library contains the *optparse*, *getopt*, and *argparse*
+modules, and out in the wild you will find many alternative command line
+interface libraries stacked on top of these, such as *cliff*, *cement*,
+*opster*, *plac*, and many others. Some of these libraries separate the command
+line interface setup of your application from the actual code, some force yet
+another argument parsing API upon you, some force you to hide your code in
+non-obvious framework constructs, and some even add dependencies on other
+modules.
+This makes you scream *aaargh*. And, lo and behold, here it is!
+
+%package help
+Summary: Development documents and examples for aaargh
+Provides: python3-aaargh-doc
+%description help
+The Python standard library contains the *optparse*, *getopt*, and *argparse*
+modules, and out in the wild you will find many alternative command line
+interface libraries stacked on top of these, such as *cliff*, *cement*,
+*opster*, *plac*, and many others. Some of these libraries separate the command
+line interface setup of your application from the actual code, some force yet
+another argument parsing API upon you, some force you to hide your code in
+non-obvious framework constructs, and some even add dependencies on other
+modules.
+This makes you scream *aaargh*. And, lo and behold, here it is!
+
+%prep
+%autosetup -n aaargh-0.7.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aaargh -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.1-1
+- Package Spec generated