summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 07:30:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 07:30:57 +0000
commit5124aca7845c2dd48dc1595d81cd7014fd903c8f (patch)
tree95f5195eb75253d9e5e254e89c0b9ce3ce7349b2
parent1c9b7b25e74884785265fddfd8f4bd73de6b3ba4 (diff)
automatic import of python-absolufy-imports
-rw-r--r--.gitignore1
-rw-r--r--python-absolufy-imports.spec210
-rw-r--r--sources1
3 files changed, 212 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index e69de29..38a3d8e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+/absolufy_imports-0.3.1.tar.gz
diff --git a/python-absolufy-imports.spec b/python-absolufy-imports.spec
new file mode 100644
index 0000000..218542f
--- /dev/null
+++ b/python-absolufy-imports.spec
@@ -0,0 +1,210 @@
+%global _empty_manifest_terminate_build 0
+Name: python-absolufy-imports
+Version: 0.3.1
+Release: 1
+Summary: A tool to automatically replace relative imports with absolute ones.
+License: MIT
+URL: https://github.com/MarcoGorelli/absolufy-imports
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/74/0f/9da9dc9a12ebf4622ec96d9338d221e0172699e7574929f65ec8fdb30f9c/absolufy_imports-0.3.1.tar.gz
+BuildArch: noarch
+
+
+%description
+A tool and pre-commit hook to automatically convert relative imports to absolute.
+<p align="center">
+ <a href="#readme">
+ <img alt="demo" src="https://raw.githubusercontent.com/nbQA-dev/nbQA-demo/master/abs-imports.gif">
+ </a>
+</p>
+## Installation
+```console
+$ pip install absolufy-imports
+```
+## Usage as a pre-commit hook (recommended)
+See [pre-commit](https://github.com/pre-commit/pre-commit) for instructions
+Sample `.pre-commit-config.yaml`:
+```yaml
+- repo: https://github.com/MarcoGorelli/absolufy-imports
+ rev: v0.3.0
+ hooks:
+ - id: absolufy-imports
+```
+## Command-line example
+```console
+$ absolufy-imports mypackage/myfile.py
+```
+```diff
+- from . import __version__
++ from mypackage import __version__
+```
+## Configuration
+### Application directories
+If your package follows the popular `./src` layout, you can pass your application directories via `--application-directories`, e.g.
+```console
+$ absolufy-imports src/mypackage/myfile.py --application-directories src
+```
+```diff
+- from . import __version__
++ from mypackage import __version__
+```
+Multiple application directories should be colon-separated, e.g. `--application-directories .:src`. This is the same as in [reorder-python-imports](https://github.com/asottile/reorder_python_imports).
+### Only use relative imports
+Use the `--never` flag, e.g.
+```console
+$ absolufy-imports mypackage/myfile.py --never
+```
+```diff
+- from mypackage import __version__
++ from . import __version__
+```
+
+%package -n python3-absolufy-imports
+Summary: A tool to automatically replace relative imports with absolute ones.
+Provides: python-absolufy-imports
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-absolufy-imports
+A tool and pre-commit hook to automatically convert relative imports to absolute.
+<p align="center">
+ <a href="#readme">
+ <img alt="demo" src="https://raw.githubusercontent.com/nbQA-dev/nbQA-demo/master/abs-imports.gif">
+ </a>
+</p>
+## Installation
+```console
+$ pip install absolufy-imports
+```
+## Usage as a pre-commit hook (recommended)
+See [pre-commit](https://github.com/pre-commit/pre-commit) for instructions
+Sample `.pre-commit-config.yaml`:
+```yaml
+- repo: https://github.com/MarcoGorelli/absolufy-imports
+ rev: v0.3.0
+ hooks:
+ - id: absolufy-imports
+```
+## Command-line example
+```console
+$ absolufy-imports mypackage/myfile.py
+```
+```diff
+- from . import __version__
++ from mypackage import __version__
+```
+## Configuration
+### Application directories
+If your package follows the popular `./src` layout, you can pass your application directories via `--application-directories`, e.g.
+```console
+$ absolufy-imports src/mypackage/myfile.py --application-directories src
+```
+```diff
+- from . import __version__
++ from mypackage import __version__
+```
+Multiple application directories should be colon-separated, e.g. `--application-directories .:src`. This is the same as in [reorder-python-imports](https://github.com/asottile/reorder_python_imports).
+### Only use relative imports
+Use the `--never` flag, e.g.
+```console
+$ absolufy-imports mypackage/myfile.py --never
+```
+```diff
+- from mypackage import __version__
++ from . import __version__
+```
+
+%package help
+Summary: Development documents and examples for absolufy-imports
+Provides: python3-absolufy-imports-doc
+%description help
+A tool and pre-commit hook to automatically convert relative imports to absolute.
+<p align="center">
+ <a href="#readme">
+ <img alt="demo" src="https://raw.githubusercontent.com/nbQA-dev/nbQA-demo/master/abs-imports.gif">
+ </a>
+</p>
+## Installation
+```console
+$ pip install absolufy-imports
+```
+## Usage as a pre-commit hook (recommended)
+See [pre-commit](https://github.com/pre-commit/pre-commit) for instructions
+Sample `.pre-commit-config.yaml`:
+```yaml
+- repo: https://github.com/MarcoGorelli/absolufy-imports
+ rev: v0.3.0
+ hooks:
+ - id: absolufy-imports
+```
+## Command-line example
+```console
+$ absolufy-imports mypackage/myfile.py
+```
+```diff
+- from . import __version__
++ from mypackage import __version__
+```
+## Configuration
+### Application directories
+If your package follows the popular `./src` layout, you can pass your application directories via `--application-directories`, e.g.
+```console
+$ absolufy-imports src/mypackage/myfile.py --application-directories src
+```
+```diff
+- from . import __version__
++ from mypackage import __version__
+```
+Multiple application directories should be colon-separated, e.g. `--application-directories .:src`. This is the same as in [reorder-python-imports](https://github.com/asottile/reorder_python_imports).
+### Only use relative imports
+Use the `--never` flag, e.g.
+```console
+$ absolufy-imports mypackage/myfile.py --never
+```
+```diff
+- from mypackage import __version__
++ from . import __version__
+```
+
+%prep
+%autosetup -n absolufy-imports-0.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-absolufy-imports -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
+- Package Spec generated
diff --git a/sources b/sources
new file mode 100644
index 0000000..e369085
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+e93b92c9a96548bd5576f3f7c3ba9e14 absolufy_imports-0.3.1.tar.gz