summaryrefslogtreecommitdiff
path: root/python-acme.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-acme.spec')
-rw-r--r--python-acme.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-acme.spec b/python-acme.spec
new file mode 100644
index 0000000..2104ab1
--- /dev/null
+++ b/python-acme.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-acme
+Version: 2.3.0
+Release: 1
+Summary: ACME protocol implementation in Python
+License: Apache License 2.0
+URL: https://github.com/letsencrypt/letsencrypt
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/aa/a36ce4a2cbee1643f26f1434d568879a70cbe7c3b976c6cedbb430947352/acme-2.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-cryptography
+Requires: python3-josepy
+Requires: python3-PyOpenSSL
+Requires: python3-pyrfc3339
+Requires: python3-pytz
+Requires: python3-requests
+Requires: python3-setuptools
+Requires: python3-Sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-pytest
+Requires: python3-pytest-xdist
+Requires: python3-typing-extensions
+
+%description
+
+
+%package -n python3-acme
+Summary: ACME protocol implementation in Python
+Provides: python-acme
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-acme
+
+
+%package help
+Summary: Development documents and examples for acme
+Provides: python3-acme-doc
+%description help
+
+
+%prep
+%autosetup -n acme-2.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-acme -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.0-1
+- Package Spec generated