summaryrefslogtreecommitdiff
path: root/python-adafruit-circuitpython-gps.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-adafruit-circuitpython-gps.spec')
-rw-r--r--python-adafruit-circuitpython-gps.spec22
1 files changed, 13 insertions, 9 deletions
diff --git a/python-adafruit-circuitpython-gps.spec b/python-adafruit-circuitpython-gps.spec
index ced9db4..5f29d6c 100644
--- a/python-adafruit-circuitpython-gps.spec
+++ b/python-adafruit-circuitpython-gps.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-adafruit-circuitpython-gps
-Version: 3.10.7
+Version: 3.10.10
Release: 1
Summary: CircuitPython library for GPS modules.
License: MIT
URL: https://github.com/adafruit/Adafruit_CircuitPython_GPS
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1f/15/c8289b8968da1122f5bb4c965f130bba5bd6488634e0510fc368af93a553/adafruit-circuitpython-gps-3.10.7.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/0d/4d/c537382513e87aba250f5f2d05bc0d5d897d8b39041a4454f5862b1a78af/adafruit-circuitpython-gps-3.10.10.tar.gz
BuildArch: noarch
Requires: python3-Adafruit-Blinka
@@ -14,6 +14,10 @@ Requires: python3-pyserial
Requires: python3-adafruit-circuitpython-typing
Requires: python3-typing-extensions
Requires: python3-adafruit-circuitpython-sd
+Requires: python3-covdefaults
+Requires: python3-coverage
+Requires: python3-freezegun
+Requires: python3-pytest
%description
GPS parsing module. Can send commands to, and parse simple NMEA data sentences
@@ -37,7 +41,7 @@ GPS parsing module. Can send commands to, and parse simple NMEA data sentences
from serial and I2C GPS modules to read latitude, longitude, and more.
%prep
-%autosetup -n adafruit-circuitpython-gps-3.10.7
+%autosetup -n adafruit-circuitpython-gps-3.10.10
%build
%py3_build
@@ -51,20 +55,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -77,5 +81,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.7-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.10-1
- Package Spec generated