summaryrefslogtreecommitdiff
path: root/python-adb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-adb.spec')
-rw-r--r--python-adb.spec122
1 files changed, 122 insertions, 0 deletions
diff --git a/python-adb.spec b/python-adb.spec
new file mode 100644
index 0000000..a626883
--- /dev/null
+++ b/python-adb.spec
@@ -0,0 +1,122 @@
+%global _empty_manifest_terminate_build 0
+Name: python-adb
+Version: 1.3.0
+Release: 1
+Summary: A pure python implementation of the Android ADB and Fastboot protocols
+License: Apache Software License
+URL: https://github.com/google/python-adb
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/06/000a3fbc5aa3100f9afef4e26f144536b81b22fe557e6a3f99d4a37593ce/adb-1.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-libusb1
+Requires: python3-M2Crypto
+
+%description
+This repository contains a pure-python implementation of the Android
+ADB and Fastboot protocols, using libusb1 for USB communications.
+
+This is a complete replacement and rearchitecture of the Android
+project's ADB and fastboot code available at
+https://github.com/android/platform_system_core/tree/master/adb
+
+This code is mainly targeted to users that need to communicate with
+Android devices in an automated fashion, such as in automated
+testing. It does not have a daemon between the client and the device,
+and therefore does not support multiple simultaneous commands to the
+same device. It does support any number of devices and never
+communicates with a device that it wasn't intended to, unlike the
+Android project's ADB.
+
+
+
+
+%package -n python3-adb
+Summary: A pure python implementation of the Android ADB and Fastboot protocols
+Provides: python-adb
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-adb
+This repository contains a pure-python implementation of the Android
+ADB and Fastboot protocols, using libusb1 for USB communications.
+
+This is a complete replacement and rearchitecture of the Android
+project's ADB and fastboot code available at
+https://github.com/android/platform_system_core/tree/master/adb
+
+This code is mainly targeted to users that need to communicate with
+Android devices in an automated fashion, such as in automated
+testing. It does not have a daemon between the client and the device,
+and therefore does not support multiple simultaneous commands to the
+same device. It does support any number of devices and never
+communicates with a device that it wasn't intended to, unlike the
+Android project's ADB.
+
+
+
+
+%package help
+Summary: Development documents and examples for adb
+Provides: python3-adb-doc
+%description help
+This repository contains a pure-python implementation of the Android
+ADB and Fastboot protocols, using libusb1 for USB communications.
+
+This is a complete replacement and rearchitecture of the Android
+project's ADB and fastboot code available at
+https://github.com/android/platform_system_core/tree/master/adb
+
+This code is mainly targeted to users that need to communicate with
+Android devices in an automated fashion, such as in automated
+testing. It does not have a daemon between the client and the device,
+and therefore does not support multiple simultaneous commands to the
+same device. It does support any number of devices and never
+communicates with a device that it wasn't intended to, unlike the
+Android project's ADB.
+
+
+
+
+%prep
+%autosetup -n adb-1.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-adb -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
+- Package Spec generated